AnsweredAssumed Answered

Magic Key Leaves One Field Empty?

Question asked by nclark4 on Aug 25, 2018
Latest reply on Aug 25, 2018 by nclark4

I got Magic Key working to carry through a portal child record to a grandchild record for all fields but ONE.  The grandchild record has the primary key, 4 fields I need copied, and some calculation fields derived from two of the four fields.  However, one of the four fields (the price field) is empty.  I have tried joining the price field but it makes no difference (that worked for the other fields). 

 

I **think** it isn't working because the price field in the child record is a number auto calculation field that only calculates once the unit and quantity are updated.  This happens in the child record after the magic key record is created.  I tried adding a refresh window and refresh object to the portal exit but that didn't work, where the grandchild price record is both a number lookup and auto calculation field set to the child record price field.  I also tried doing it manually and it didn't work.  I am still learning about how these work so if I can do something better or else that would be helpful to know.

Outcomes