AnsweredAssumed Answered

<File Missing> on Go & SDK

Question asked by obospieler on Aug 27, 2018

I am having an issue where from time to time some Go Clients (Never happens on Pro) get "<File Missing>" forever.  I cannot even get the file to work again either by restarting the device or quitting the FM GO app1.  In fact when it happened (twice now), all I can do to get connected again is actually uninstall FM Go and then install it again.

 

It happened to a couple of iPad Tablets a few months back (just before 17 came out).  When 17 rolled we I deployed all our FileMaker solutions through an MDM server using the iOS SDK so the users are just opening "apps" instead of having to "add hosts, enter host name...".  Then the issue happened again (got "<File Missing>") but with all the devices.  This forced me to remove all the iOS SDK apps via the MDM server and add them back again.

 

Has anyone else experienced the issue where the only way to get FM Go to connect again is by doing a re-install of the all?

 

The issue ("<File Missing>") is also made worse in that no script can be run because the file is missing.  When I run updates, I be sure to disconnect all users before I do anything (not to mention the Go Clients all have the fmreauthenticate privilege set)

 

Here are my details if you think the specifics will help.

 

  • All iPad tablets are iOS 11.2+
  • All iPad Tablets are using the FM iOS SDK for FM 17
  • All iPad Tablets are in DEP/Managed/Supervised through the Cisco Meraki MDM
  • All the iOS SDK files are just launchers that open the hosted FileMaker solution files.
    • There is zero "local" data.  Just as we did with Go.
    • There is no Sync, no fields, just a script that opens the hosted file.
  • The FileMaker solutions file is hosted on a Windows 2012 R2 server hosted on the AWS cloud with FMS 17 (the latest/no updates available).

 

Again, all FM Pro clients (all on Windows PCs except me as the developer) have no issues

 

 

1. I've tried all three methods:  1. Just pressing the home button, 2. Double tapping the home button and swiping up to quit the app and 3. Pressing and holding the power button, then pressing and holding the home button (called "forest quit")

Outcomes