AnsweredAssumed Answered

do permissions changes cause FMS16 to crash or just corrupt files?

Question asked by sully1570 on Sep 10, 2018
Latest reply on Oct 24, 2018 by thomas_staehli


I've noticed that changing permissions on a file hosted in FMS 16 tend to turn my office upside down.

 

I thought the problem was probably related to the permissions changes being for large, wide tables that had multiple calculations for limited record access (certain permission sets can see records only from specific dates, sources, etc).

It would make sense that a complex change that would require the permission set's name to be added/removed from each record would turn a file into a brick while the server recalculated the permissions for each record, one by one.

The file usually has one or two dozen clients logged in at the time, so I just assumed that any big permissions edits should be made after hours.

 

Or so I thought.

 

Today I ground the whole office to a halt by changing permissions for a table with only 5 records and about 20 fields.

All I did was change an existing permission set to be able to view a calendar layout, table and records and edit all fields (no create records, no delete records).

The table isn't related to other tables - the script that populates the data field does so by performing a script on the server and passing back JSON to the client as a script result so that it doesn't have to be related to anything at all.

There are already about 6 other permission sets that are successfully using the same layout, table and records in the same way.

 

So I figure "no problem, this should be fine."

Instead of making the permissions change, the file stopped functioning.

 

Every client who had the file open froze.

The file won't let any new clients open it.

Tried disconnecting all the clients in FMS16 console - says they're all gone.

Tried pausing the offending file on the server and it wouldn't pause - it just says "pausing" for five minutes and then goes back to "Normal" with 19 clients still attached to it (which is nuts because I disconnected everyone).

Tried pausing other files from admin console.  Nope.

Tried connecting to other files on the server.  Nope.

Gave up fixing it and tried to reboot the server.

Now we all get to wait together while the 3.9GB file verifies (clocked in at 72 minutes).

 

So I have two dozen people in my office all staring at me like I shot their pony.

 

For 72 minutes.

 

And of course, when the file finally comes back online, the permission set I wanted to change is what I changed it to but not what i need - I missed the checkbox for allowing URLs to perform filemaker scripts so I get to REPEAT this process.

 

Now I wish I was one of the ponies.

 

I just don't get it.

 

Anyone have any ideas as to what makes permissions changes so deadly?

Outcomes