AnsweredAssumed Answered

Permission Denied on FMS17 CWP IIS PHP Page

Question asked by jcooper on Sep 14, 2018
Latest reply on Sep 20, 2018 by jcooper

(That enough acronyms for ya? )

 

Hi All,

 

After years running FMS off Mac I switched to Windows, so I'm a bit rusty. I'm setting up a windows 2016 server with FMS17. Single Machine Deployment (for now, will likely add a second worker machine at some point) and I have a PHP site that works fine from my current Mac server.

 

Following FMI's directions I copied my php folder into C:\Program Files\FileMaker\FileMaker Server\HTTPServer\conf. I get an Access Denied when loading the site. I tried setting up an "Application" in IIS and pointing an alias to a folder in C:\Program Files\FileMaker\FileMaker Server\Web Publishing\web-server-support  like the fmi-test site (which does work, btw) but it doesn't work either.

 

I compared the two sites and they look like the same setup.

 

I tried making a folder inside conf and dragging the individual files into it, but it didn't work either.

 

BUT, If I make a folder and stick an index.htm file in it, it works! So I'm guessing it's some windows/php thing but I sure can't find what it is.

 

Help?

 

Thanks,

 

Jeff

Outcomes