AnsweredAssumed Answered

Find script not working like I think it should

Question asked by wcallman on Sep 21, 2018
Latest reply on Sep 21, 2018 by wcallman

Here is the script:

NOTE: dashes are used to separate steps

 

Sort Records by Field[descending Master:;zzzserial_number]

 

Perform Find[Restore] -Specify Find Request- -Action-  Find Records  -Criteria- Master:Intake_YB Chkbox:[=Yes]

       NOTE: I also tried setting [=Yes] to [="Yes"] and get the same result

 

Perform Find[Restore] -Specify Find Request- -Action-  Omit Records  -Criteria- Master:Name_LastName:[!]

 

Sort Records by Field [Ascending ; Master::Name_LastName]

 

Export Records [With dialog: On; Create directories; Off ; unicode (UTF-16)]

 

 

This find brings back 430 plus records of which 324 are not checked yes.

When I click the find icon click and manually click on the YB check box and perform find it brings back the 106

correct records.

I need to automate this process for my client to generate an Excel spreadsheet. hence the script.

 

My logic on the script set up:

The sort puts the newest record first so when the second find (omit) runs it leaves the newest record.

 

 

Any thoughts?

 

I know it is something simple, it usually is.

Outcomes