AnsweredAssumed Answered

Disappearing Portal Records

Question asked by j.hall on Oct 10, 2018
Latest reply on Nov 8, 2018 by FileKraft

Having an issue with items in a portal disappearing. There doesn't seem to be any reason for it. The schema of the database hasn't changed. It's all Windows 10 clients with a mix of FileMaker 16 and FileMaker 17. There doesn't seem to be any sort of predictability on it occurring. All the clients and Server are updated (FileMaker Server 17).

 

Happens to different users at different times. But I want to stress the related records are NOT being deleted. They are there, and if a user that's seeing the problem closes FileMaker and restarts it, everything is back where it should be. Today, I opened up the same parent record as the user (I'm in a different location than the user) and I was showing all the items.

 

It seems to be happening to 2 specific ports on 2 specific layouts. It's a multi-file solution, but the parent and child records are in the same file. We initially thought it was related to only 17 and thought it went away after updating to 17.02. But now we are seeing it everyday at some point, and the client doesn't seem to matter. There is nothing out of the ordinary on the server, it's not being overly taxed or running out of hard drive space or memory. The CPU is peaking at about 7% (And that correlates to backup times).

 

I'm just at a loss and can't seem to find any rhyme or reason for this. Any help would be appreciated.

Outcomes