AnsweredAssumed Answered

Invalid table key - Error 8493

Question asked by jdressing on Oct 11, 2018
Latest reply on Oct 13, 2018 by gdurniak

Any time I run a recovery on our database, I get this bazar message...   there are problems found, but the errors it lists are all 0 found.   Then I go into the recovery log and find Resetting invalid table key then that the item changed.  So if it changed the table key, why when I run it over and over, it appears to change the exact same table key?  I even tried this on an empty clone - it is NOT data related.  It is pretty lame that it tells me to not use the file going forward.  That is NOT an acceptable message.  We have lived with this message for years and it does not appear to hurt anything.  It is just alarming why it thinks the key is invalid.  Relationships on that key work perfectly.   Removing and re-adding that key field would cause major chaos across tons of table occurrences and scripts... so I really don't want to do that.  I guess if that is the only option, I could remove it, then using FM Perception, it could show me everywhere that it broke.

 

Does anyone have any better ideas on how to fix this? (Please do not respond if you are going to tell me to go to a previous version...  that is not an option)  It would be nice if when it rebuilds the recovery file that it would rebuild the table key correctly... this really makes no logical sense.

 

Key parts of the Recovery Log that describe the error:

Recovering: field catalog 'Site'

2018-10-11 15:34:26.825 -0400 iPerformance.fmp12 0   Rebuilding field catalog 'Site' order list: name

2018-10-11 15:34:26.826 -0400 iPerformance.fmp12 0   Rebuilding field catalog 'Site' order list: custom

2018-10-11 15:34:26.828 -0400 iPerformance.fmp12 0   Rebuilding field catalog 'Site' order list: type

2018-10-11 15:34:26.830 -0400 iPerformance.fmp12 0   Recovering: field 'Site Name' (1)

2018-10-11 15:34:26.831 -0400 iPerformance.fmp12 0   Recovering: field 'Address 1' (2)

2018-10-11 15:34:26.832 -0400 iPerformance.fmp12 0   Recovering: field 'Address 2' (3)

2018-10-11 15:34:26.833 -0400 iPerformance.fmp12 0   Recovering: field 'City' (4)

2018-10-11 15:34:26.834 -0400 iPerformance.fmp12 0   Recovering: field 'State' (5)

2018-10-11 15:34:26.836 -0400 iPerformance.fmp12 0   Recovering: field 'Zip' (6)

2018-10-11 15:34:26.837 -0400 iPerformance.fmp12 0   Recovering: field 'ProjectID' (7)

2018-10-11 15:34:26.838 -0400 iPerformance.fmp12 8493   Resetting invalid table key

2018-10-11 15:34:26.840 -0400 iPerformance.fmp12 8476     This item changed

2018-10-11 15:34:26.841 -0400 iPerformance.fmp12 0   Recovering: field 'SiteID' (8)

 

WARNING: problems were detected while recovering the database.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file.

2018-10-11 15:43:47.315 -0400 iPerformance.fmp12 0 File blocks: scanned and rebuilt 17811 block(s), dropped 0 invalid data block(s)

2018-10-11 15:43:47.316 -0400 iPerformance.fmp12 0 Schema: scanned fields and tables; some problems were found...

2018-10-11 15:43:47.317 -0400 iPerformance.fmp12 0   fields created to match record data: 0

2018-10-11 15:43:47.319 -0400 iPerformance.fmp12 0   field values deleted due to invalid ID or repetition: 0

2018-10-11 15:43:47.320 -0400 iPerformance.fmp12 0   records deleted due to invalid ID: 0

2018-10-11 15:43:47.321 -0400 iPerformance.fmp12 0 Structure: scanned; 1 item(s) modified

 

This database is running on FileMaker 17 Server, but the issue existed while running in previous versions of FileMaker.

We run it hosted on FileMaker 17 Server, but again - this recovery message happens when running stand alone and was the same on FileMaker 16.

Outcomes