sccardais

Solution: Disappearing Scripts in Workspace

Discussion created by sccardais on Oct 16, 2018
Latest reply on Oct 16, 2018 by sccardais

I haven't seen anything about this elsewhere and wanted to share with others.

 

When I launched FMP 17.02 (Mojave OS) this morning, I got a warning that FMP required Java 6. I use FMP daily and wondered why I suddenly got this message.

 

Then, after installing Java 6, I discovered that I could no longer view any of my scripts in Script Workspace. They were all listed in the left panel and they all seemed to function but the script steps didn't appear in the workspace to the right so I could view or edit the scripts.

 

I remembered that I installed Base Elements from Goya yesterday and ALSO checked "Allow Solutions to Install Files" in Preferences > Plug Ins.

 

Unchecking both solved the problem.

 

Leaving Goya's Base Elements checked but disabling "Allow Solutions to Install Files" also solved the problem so it doesn't look like an issue with Goya's Base Elements.

 

I realize this isn't an exhaustive test but wanted to share it in case this happened to someone else. The person I spoke with at FileMaker support didn't seem to be aware of this issue specifically but acknowledged that there were issues with Mojave that might be at the root of the problem.

 

In short, unchecking "Allow Solutions to Install Files" brought back my ability to view and edit all of my scripts with Goya's Base Elements active.

Outcomes