AnsweredAssumed Answered

MapQuest Mail PDF not working

Question asked by roryduffy on Oct 26, 2018
Latest reply on Oct 30, 2018 by TSGal

Product and version: FileMaker Pro Advance v17.0.2.205

OS and version: macOS High Sierra v10.13.6

Browser and version (for WebDirect only): N/A

Hardware: MacBook Pro (15-inch, Mid 2012)

 

Having issues with maps appearing on PDFs. Every time I command-print, Mail PDF, the map window refreshes itself and I get a blank map. Is there a n alternative method of doing this? Is there a recommended map that's more compatible with FileMaker v17 Advanced -- Google, MapQuest?

Pasted below previous history and attempts to get around the issue.

Cheers

Rory

 

MapQuest Mail PDF not working in Discussions

Rory Duffy asked7 months ago

Hi,
I'm trying to Mail PDF a map out of Filemaker but the map keeps refreshing and coming out on the PDF as a refreshed version (rather than the map). Any ideas?

I'm using MapQuest rather than Google (as that seems to be the recommended and only map that is compatible in Filemaker Pro)

I'm using Filemaker Pro v16, command-P (Print) Current record, From: 3 to 3

Thanks

Rory

 

3 replies

2 new updates

 

Rory Duffy (to Rory Duffy) 7 months ago

Hi,
I've Googled around but can't seem to find anyone who has the same issue in MapQuest, or any solutions in this forum (have tried keywords "MapQuest", "web viewer", "refresh", "PDF" etc.)

 

So it might just be my setup. Anyway, I've just tried it in Filemaker Pro v15 and it works fine, so I'm guessing it's a glitch in Filemaker Pro v16 and I'll just have to remember to open my database in v15 before exporting a map (unless there is any other solution?)

 

The problem I have with Google Maps is that there is a massive sidebar that takes up most of the web viewer, yet when I try to remove the sidebar, the icon showing the point to which the Google Map is encoded to disappears (so, for example, if I'm sending venue details, it won't show where the venue is on the map; just the map - hence why I've been using MapQuest).


But MapQuest seems to work fine in v15 so that's my solution!
Cheers

Rory

 

 

Rory Duffy (to Rory Duffy) 5 months ago

Hi

Still having the same issue.

I've updated to v16.0.5.500

But the update doesn't resolve the issue. The map viewer keeps refreshing every time I try to export the PDF.

This means that whenever I have to generate a document with a map, I have to close the solution and open it up in v15 to generate the PDF.

It also means I'm sometimes erroneously creating duff records when I run the new record script and my card popup windows don't appear (introduced in v16).

Is there a way around this?

Thanks

Rory

Outcomes