AnsweredAssumed Answered

FMP Ad17 did not save data changes?!

Question asked by nounours777 on Oct 29, 2018
Latest reply on Nov 1, 2018 by besjes

Never happened to me until today:

 

Data changes (creation of a bunch of records, and entries in related tables) were not saved, even not when database file was closed.

 

The User was working on a local FM file with FMP Ad17 (17.0.2.205) on MacOSX. She opened the file, worked for about an hour on data entry, left the computer alone for several hours. Came back, re-entered password, performed some script, closed the database. No error, no crash. The database file was not touched - the modification date still showed the date from the last modification some days ago.

 

She called me in alert, I did see that the file was not touched. And she printed the data she entered (as they were orders to a supplier), and I also see in the media folder files she added - so I have pretty much of a proof that there was no user error involved. My data entry is pretty basic: A script copies some data from a template, creates a new record, fills the data in. Then the user adds some data, some directly, some through portals with creation of related records. All straight forward, tested, used for months. Do not see any possibility of mismanipulation.

 

Ok, the data is gone. We can reconstruct the data, it will take an hour or two. BUT: This incident scares me. I never had something like this in may years of working with Filemaker. Can this happen again?

 

Did ever someone of you experience something like this? Any explanation?

 

I tried to check, looking for cache data, checked the file for corruption, checked the console for errors - nada. Just as if the file would never have been opened. Strange.

 

Gilbert

Outcomes