AnsweredAssumed Answered

Bug? I cannot hide an object in Find mode (only)

Question asked by wimmmmm on Nov 23, 2018
Latest reply on Nov 23, 2018 by comment

In the data panel, we have the option to "Hide object when (condition)" and a separate toggle to "Apply in Find mode".

Maybe I'm confused, maybe this doesn't really work as intended.

 

Step 1

What I did:

  • I select a field
  • I set condition to "True"
  • I enable "Apply in Find mode"

 

What I expect:

  • the field should be visible in Browse mode
  • the field should be hidden in Find mode

 

What I experience:

  • the field is NOT visible in browse mode nor Find mode

 

Conclusion #1: the checkbox doesn't mean Hide in Browse OR Hid in Find, it's doing both at same time

 

Step 2

What I did:

  • I select a field
  • I set condition to "True"
  • I do NOT enable "Apply in Find mode"

 

What I expect:

  • the field should be hidden in Browse mode
  • the field should be hidden in Find mode

 

What I experience:

  • the field is NOT visible in browse mode
  • the field IS visible in Find mode

 

So in the first case "Apply in Find mode" does THE SAME for Browse and Find, in the second case it does the opposite.

So I cannot hide a field in browse mode, and only show it in Find mode using these two settings.

 

Step 3 & 4

What I did:

  • I copied step 1 and 2
  • now put the condition to False

 

Result: step 3 & 4 ALWAYS show - kinda logical, the condition to hide is set to false.

 

Desired solution

So practically I cannot do what I wanted to do in the first place:

  • show a field (in read-only formatting) only in Browse mode
  • show a copy of the same field on the same position with a pop-up menu only in Find mode, to easily select one of the allowed values to choose while searching.

 

Workarounds?

Outcomes