AnsweredAssumed Answered

[FileMaker][FileMaker JDBC]  (802): Unable to open file when trying to connect from "client" application

Question asked by michaelpbreen on Dec 11, 2018
Latest reply on Dec 12, 2018 by fmpdude

Resolved: Faulty license key. Reinstalled with a different key and is now working. Just to be sure it was the key and not something else resolved by a clean install, I reinstalled again with the bad key and had the same issue (802 error).

 

Thanks

 

 

 

Hi Folks,

 

Been looking for an answer for a few hours now, so time to post for help. I have seen many instances of this issue from other postings, but I cannot figure out my issue. In trying to connect to my FMP Advanced 17 database via a JDBC client application (RazorSQL) installed on the same machine, I get the following error (FM is running and the database is open):

 

Screen Shot 2018-12-11 at 3.47.20 PM.png

I think I have tried everything suggested to others that have experienced this error and I consistently get the same results. Even more frustrating, I have this working on another machine with an older version of FMP Advanced (v14) and older version of macOS (10.11.6).

 

The current setup is FMP Advanced 17 on macOS 10.14.1 and I have matched the configuration I have on the working setup:

 

Screen Shot 2018-12-11 at 3.47.32 PM.png

 

Doing everything as "Admin" with "Full Access" (matched the config on the working setup):

 

Screen Shot 2018-12-11 at 3.57.19 PM.png

 

Screen Shot 2018-12-11 at 3.57.09 PM.png

 

Screen Shot 2018-12-11 at 3.59.52 PM.png

 

I have tried this from two different applications (RazorSQL and OfficeLibre) with the same result.

 

Any and all advice is appreciated.

 

Thanks,

 

Mike

 

Adding more info as I find it. Port 2399 is reserved for FMP:

 

Screen Shot 2018-12-11 at 4.31.28 PM.png

Outcomes