AnsweredAssumed Answered

FMS17 database converts to read-only

Question asked by HelpMeRandy on Dec 14, 2018
Latest reply on Dec 26, 2018 by HelpMeRandy

FMS17 (ver 17.17.0.2.203) on Mac Mini, <10 users, 1 database/3 tables, 3k records with container fields, Mac and Win users all on FMA 17 - 30+ yrs of Mac tech support and 20 yrs with FMPro

-----------------------

After opening a case with tech support a couple of weeks ago I was instructed to Get Info on the Data folder within the FileMaker Server folder and re-apply the permissions like so:

fmserver: Read & Write

fmsadmin: Read & Write

everyone: Read only

 

That worked until several days later it became read-only again. I re-applied the permissions. That worked until the next day or so when it did it again, etc., etc…Longest successful period of activity has been 3 days.

 

Note: The permissions in the Get Info panel don’t show any change to the permissions but the database itself could only be viewed by the users. Saving an edit brings up an error that denies permission to save changes.

 

The FMS14 server and FM14 client software were working fine but once I upgraded to FMS17 this has become an ongoing issue.

 

Any clue as to what could be causing this?

Outcomes