AnsweredAssumed Answered

Insert from URL / Specify cURL options not working

Question asked by dewitte on Jan 6, 2019
Latest reply on Jan 6, 2019 by dewitte

Hello!  I have an Insert from URL that works great in FileMaker 17 and 16 when I run it in a native application.  However, when I run the same command on WebDirect, it does not work.  In fact, the $httptrace doesn't show anything.  I've tried some experimentation and I found that if I run the code in the native app on FileMaker 17 using Perform Script On Server, it also does not return a value or $httptrace.  So I'm thinking it has to do with the server.

 

I'm asking only to get some verification from the experts (you).  The server version is 15.0.3.  We currently run an older server version since there are many people still running an older FileMaker on their systems.  I've tried running a curl command on the server in a terminal window and it does return a value, so the issue does not seem to be anything with connectivity.

 

Do you think that the command isn't running only because of the server version being older and not supporting the newer version of Insert from URL with cURL options?  When I was working on this at first, I thought I read an article that the cURL options was a feature in the newer version of FileMaker.  I also saw that you could not insert into a variable on Server 15, so I rewrote the routine to use a field instead, but it still fails as if the cURL options are not getting passed.

Outcomes