AnsweredAssumed Answered

Set Web Viewer not launching fmp url on Windows

Question asked by fmdataweb on Jan 17, 2019
Latest reply on Feb 4, 2019 by user19752

I have a Web Viewer on a layout and I run a script which generates some HTML code, then sets this into the Web Viewer which then performs the fmp url script which is part of the HTML code. This works fine on Mac OS X but I've just discovered that this is not working on Windows - the script runs, sets the Web Viewer but the fmp url doesn't run.

 

I'm setting the html in a variable in the script then I perform this step:

 

Set Web Viewer [ Object Name: "webViewer"; URL: "data:text/html," & $htmlCode ]

 

On Mac OS X this immediately calls the fmp url script but on Windows it doesn't.

 

The HTML looks like this (have removed unnecessary Javascript):

 

<html>

<body>

<script language="JavaScript" type="text/javascript">

location.href='fmp://$/fmDemo?script=processWeb&param='+signedKey;

</script>

</body>

</html>

 

I've tried changing location.href to window.location etc but nothing so far has resulted in the script running when the Web Viewer is set on Windows.

Outcomes