innodat

Serious Issue with FileMaker Data Migration Tool

Discussion created by innodat on Jan 31, 2019
Latest reply on Feb 4, 2019 by TSGal

Field indexing seems to perform better in the latest version.

 

However, stored calculations appear as empty or zero in the migrated file, which renders the tool useless.

 

We noticed this in a most simple calculation in on of our files, which only uses fields from the local (base) table:

LocalTable::Duration [Indexing All, Do not evaluate if all source fields are empty] = LocalTable::End Time - LocalTable::Start Time

 

We have checked the source file: the field in question contains correct calculation results in all 434'000 records.

 

Populating a Clone with the Data Migration Tool, the field is now zero in all 434'000 records. It seems that the values of the stored calculation were simply not transferred. I can "kick-start" the stored calculation by changing the indexing or "Do not evaluate if..." options of the calc field. FileMaker will then update the 434'000 records.

 

We repeated the process 5 times - same result every time. I ran a recovery (only) updating field indexes before (in the source) and after (in the destination) file - no change. Doesn't seem to be related to the index, but the field information itself which didn't transfer.

 

We are working with a solution that consists of 105 separate database files and a total of 7'374 fields. We simply cannot check and manually update every stored calculation...(!). And naturally, we should be in production in two weeks.

 

Anyone with similar experiences?

 

@ TSGal - I searched the forums, but didn't find anything comparable. Any ideas from your end?

 

Many thanks, Michael

Outcomes