AnsweredAssumed Answered

Problem with BaseElements 64 bit plugin

Question asked by mark_b on Feb 2, 2019
Latest reply on Feb 5, 2019 by mark_b

I love the BaseElements plugin (thank you Nicholas). When I upgraded to FMP-17 64 bit, I installed the latest 64 bit version for Windows (running Windows 10 on 64 bit system). I noticed that the BE_ListFilesInFolder no longer worked (works fine in 32 bit version in FMP-16 32 bit: 3.3.7). The 64 bit version works fine as long as I'm not going to a mapped folder. Here's the script from both versions.

The Debugger shows that the BE_SelectFolder works. It returns "R:\" from:

But when I pass $Folder into the BE_ListFilesInFolder, it returns "?" in the 64 bit version of FMP-17. But when I run the same script in FMP-16 32 bit system, it returns the list of files. I also tried using the SelectFolder to go to the folder directly (not the mapped drive R, but the long way and the same results occur. However, it (64 bit) works if I go to any non-mapped folder. Another thing I noticed with the 64 bit version is the version number is messed up when going to Edit | Preferences | Plug-ins (see below). Any ideas?

Cheers,

Mark

Outcomes