AnsweredAssumed Answered

Using a Field Value from an Unrelated Table

Question asked by barb8383 on Feb 2, 2019
Latest reply on Feb 2, 2019 by barb8383

I'm still trying to figure out how FMP 17 works, since I haven't programmed in it for years.

 

I did a little test where I tried to reference a field value in an unrelated table. In one test it worked, and in what seems to me to be an identical test, it didn't. I can't figure out the difference.

 

Here are the specifics.

Table1 and Table2 are unrelated.

Table2 is empty.

I have a layout for Table1 open and I have a current record.

 

Then I run this script:
New Window: Document Using Layout Table2
Set variable $test Table1::(a field)

 

When I look at the data viewer, it shows me
Table1::Favorite Color "purple"

 

But when I do the identical test with pet name instead of favorite color, the data viewer shows
Table1 Unrelated Table

and won't let me access the value of the current record in Table1.

 

So my question is, why do these two examples give me different results? Either the table has to be related or it doesn't. There must be something different about the examples, but I can't figure out what it is.

 

I'm going to attach screen shots that hopefully show everything needed to help me figure this out.

 

Thanks in advance.

Attachments

Outcomes