AnsweredAssumed Answered

Scripting error 409 after upgrading to FM Server 17

Question asked by diquito on Feb 12, 2019
Latest reply on Feb 20, 2019 by diquito

Hi, all Filemaker gurus!!

 

I have a strange error that I got on our server since I upgraded to FMS 17. I had a script that imported a file into a table, and it worked perfectly before the upgrade.

 

Now after the upgrade, I get import error 409 ( import order is wrong) ONLY when I run the script scheduled. If I execute the script from a client on the server, it works perfectly.

The import script step has a full path to the file which is located on the correct structure under the "FileMaker Server" path.

 

I have entered the script step to try to use other path options and when it fails I don't get the option to see the source fields mapping. As soon as I enter the full path I do see source field mapping. But when I run the schedule I get error 409?? As a note, the error 409 only showed up after I added the Get (LastError) into the script before I got the error 2020 in the event log.

 

I wonder if it's a bug? or am I missing something?

Outcomes