AnsweredAssumed Answered

Log issue with Data Migration Tool 17.0.3.304

Question asked by duncanbaker on Mar 8, 2019
Latest reply on Mar 18, 2019 by user30605

Product and version: FMDataMigration 17.0.3.304

OS and version: macOS 10.14.3

Hardware: MBP

Description:

 

Having just completed a data migration using the most recent version of the tool, I believe there's an issue with the log created by the tool when using it in verbose mode and a full access account.

 

This was observed across multiple tables and affected fields. Note I have not found any issues as yet with the actual data and indexes - this only refers to the log created by the tool.

 

If a new field is created in the destination file, the log, I believe, should make an entry saying: No compatible source found for target field "field_name"

 

However, I have noticed that if the destination field is indexed then this entry is not created but a Rebuilt Indexes entry is created:

-- Rebuilt the following indexes --

   Target field "field_name"

 

Not sure what the index is being rebuilt with as the field is empty in all records in the destination file as there's no data in the source file to populate it with.

 

Hopefully this is just related to the log, but I find that log to be very useful in terms of running through it and ensuring any constant fields used in relationships in the new file get populated before sending it live.

 

 

How to replicate:

Set up a new field in the destination file, ensure it is indexed by using in a relationship or turn on the indexing in the field. (Note this issued was found to exist when using constants for relationships.)

 

 

Workaround (if any):

None

Outcomes