theOtter

Paragraph spacing increases by factor of 10 on FileMaker Go

Discussion created by theOtter on Mar 14, 2019
Latest reply on Mar 18, 2019 by TSGal

FileMaker Pro 17.0.4 Advanced / FileMaker Go 17

macOS 14.0.3 / iOS 12.0.4

MacBook Pro (15-inch, 2016) / iPad MR7J2LL/A

 

The issue involves dictation on iOS when “Line spacing: Below” is set to greater than 0.

  • When using the keyboard in macOS, the spacing is correct.
  • When using dictation in macOS, the spacing is correct.
  • When using the on-screen keyboard in iOS, the spacing is correct.
  • When using dictation in iOS, the spacing is way off. It appears correct during the dictation, but as soon as the user presses “Done”, the line spacing increases approximately tenfold. This new line spacing is reflected across all devices, including desktop computers.

 

This bug has been replicated in multiple databases, both hosted on FMS and installed locally on the iPad. It can be replicated by setting “Line Spacing: Below” to any number greater than zero and using dictation in the field so defined.

 

Workarounds:

  • Set “Line Spacing: Below” to 0.
  • Don’t use dictation on iOS.

Attachments

Outcomes