jscooper

Installing FMS10 on MacOS 10.6.8

Discussion created by jscooper on Nov 30, 2011
Latest reply on Dec 29, 2011 by jscooper

Hey All,

 

I'm trying to help someone get FMS 10 installed. They're getting the "An unknown error has occurred" Java message while trying to run the Admin console. The database server IS RUNNING. Clients can connect to the host and see the FMServer_Sample.fp7 we all know and love. I know this was a problem a while back and I thought it got fixed with subsequent updates (Java and/or OS and/or FileMaker).

 

Anyone know what I might be missing?

 

Thanks!

 

Jeff

 

Setup:

Mac OS 10.6.8 (not mac OS Server; just regular Mac OS).

FMS 10

Java 6 (1.6.0_29_b11-402). tried with both 32 & 64 bit listed 1st in Java Prefs -- though I don't think FM went to 64 bit until 11 I figured it was worth a shot

Firewall is off; port scan checks out.

Cleared java cache between tries

Tried uninstalling/reinstalling

Rebooted a couple times

 

Java console follows:

Java Web Start 1.6.0_29

Using JRE version 1.6.0_29-b11-402-10M3527 Java HotSpot(TM) 64-Bit Server VM

User home directory = /Users/THEUSER

----------------------------------------------------

c: clear console window

f: finalize objects on finalization queue

g: garbage collect

h: display this help message

m: print memory usage

o: trigger logging

p: reload proxy configuration

q: hide console

r: reload policy configuration

s: dump system and deployment properties

t: dump thread list

v: dump thread stack

0-5: set trace level to <n>

----------------------------------------------------

Could not launch from cache. Will try online mode. [Some of required resources are not cached.]

Using standard JNLP Launcher

Show stack traces: log

Arg = keep-alive-interval=60

Arg = log-level=WARNING

Arg = carrier-stream-provider=com.ulcjava.base.shared.TrivialCarrierStreamProvider

Arg = url-string=https://localhost:16001/adminconsole.ulc

Arg = launchtype=initial-single

Arg = server-language=en

Arg = server-timezone=America/New_York

AdminConsoleJnlpLauncher - using allCertsTrustManager

AdminConsoleJnlpLauncher - Installing custom trust manager

AdminConsoleJnlpLauncher - Register HttpURLConnection

AdminConsoleJnlpLauncher - finished installing custom trust manager

AdminConsoleJnlpLauncher - installing File Service

AdminConsoleJnlpLauncher - installing Browser Service

AdminConsoleJnlpLauncher - createSessionStateListener()

ULC Client Error:An unknown error has occurred.

com.ulcjava.base.client.RemoteException: Exception occured on the server: java.lang.NullPointerException

at com.ulcjava.base.client.UISession.b(UISession.java:317)

at com.ulcjava.base.client.UISession.handleRequest(UISession.java:7)

at com.ulcjava.base.client.UISession.b(UISession.java:227)

at com.ulcjava.base.client.UISession.access$2700(UISession.java:180)

at com.ulcjava.base.client.UISession$5.run(UISession$5.java:1)

at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)

at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:677)

at java.awt.EventQueue.access$000(EventQueue.java:85)

at java.awt.EventQueue$1.run(EventQueue.java:638)

at java.awt.EventQueue$1.run(EventQueue.java:636)

at java.security.AccessController.doPrivileged(Native Method)

at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)

at java.awt.EventQueue.dispatchEvent(EventQueue.java:647)

at com.ulcjava.base.client.FilteringEventQueue.dispatchEvent(FilteringEventQueue.java:18)

at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)

at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Outcomes