AnsweredAssumed Answered

11 Pro v4 and OSX keychain

Question asked by shearn on Nov 30, 2011
Latest reply on Mar 22, 2012 by shearn

I'm running OSX 10.6.8 and just re-installed all the FileMaker 11 apps due to crashing problem when quitting. After upgrading both 11 Pro and 11 Pro Advanced to v4 from v2 I've noticed that 11Pro v4 cannot talk to the OSX keychain. 11ProAdvanced v4 has no problem. My credentials, when entered manually, work fine so I know it's not an authentication issue. The fact that Advanced has no problem tells me there's nothing wrong with the keychain either. I also noticed that if I go to a particular password in the keychain utility and go to the Access Control tab and manually add 11Pro v4 to the list of apps, it doesn't save.

 

I had initially installed 11Pro v2 and it worked with the keychain without any problem. I haven't tried with v3 yet.

 

There are some archive posts about this from August but no solution (apart from someone claiming a restart had fixed it for them; didn't help me). Another factor that may be important is that I have multiple copies of FileMaker (Pro, Advanced, versions 7-11) installed although only one of 11Pro.

Outcomes