4 Replies Latest reply on Dec 13, 2011 6:33 AM by SEG-IT-Support

    New record on an external table doesn't work during a scheduled script?

    SEG-IT-Support

      Hello,

       

      I'm having some troubles with one of my scheduled script.

       

      To situate a little bit the environnement, I have 1 file with a log table and a few scripts and another file with lots of tables ( in this case I just need to create records in one of those tables)

       

      The scheduled script (which is in the file with the log table) does the following actions:

       

      - connects to a webservice to get some records

      - Save the records in a log table

      - Update the records in the other file or if the record doesn't exist create a new record

       

      When I run the script using filemaker pro client, I don't have any issues, but as soon as I run the script from the server, I get an error.

       

      I searched for the problem by disabling script steps and the only part that doesn't work is the "new record" script step. Updating existing records in an external table works fine though.

       

      Any idea what could be the problem?

       

      Thanks in advance

       

      Thomas