1 2 Previous Next 15 Replies Latest reply on Jan 12, 2012 3:07 AM by comment

    Problem with file time format

    vittofm

      I've been developing a solution for a customer of mine for many years.

       

      I use FM 10 Pro Advanced.

       

      When I update the solution, I usually create an empty file and import data from the customer's backup

       

      I never had problems, 'til I upgraded my Mac Pro to Lion.

       

      The file format for "hour" fileds has always been hh.mm

       

      Now, with Lion, I cannot enter values in time fields with the desired hh.mm format. Both in Mac and Windows (several versions tested) File Maker asks for the hh:mm:ss format, and there's no way to go back to the previous situation. I tried to test the file options related to system formatting options in several ways but with no success.

      I cannot accept the new situation because hh.mm format is used in tons of script and controls.

       

      Can anybody help me? How can I set the file input format for time fileds back to hh.mm?

       

      Thanks

        • 1. Re: Problem with file time format
          FileMakerProRocks

          This sounds like the known Java problem on Lion. There were discussions before about this issue. At this time it was recommended use custom date and time settings using the field inspector. I am not aware of other fixes.

          1 of 1 people found this helpful
          • 2. Re: Problem with file time format
            geeksharka

            I am perhaps not clear on the exact issue -- but you should be able to set that Time field's formatting to hh:mm in layout mode; and it will accept similarly entered data (without seconds).

             

            Should that not answer your needs, you can also create a new field that will take the Time field's value, and format it perfectly via a calculation-value setting in the field's options -- or if you prefer, by attaching a script-trigger to the field that manages the field formatting upon or after entering a value.

            1 of 1 people found this helpful
            • 3. Re: Problem with file time format
              vittofm

              Thank you very much for your help.

               

              The problem is that, even if I use custom settings, I'm not allowed to use the hh.mm format. It keeps on asking me to enter the hh:mm:ss format

              • 4. Re: Problem with file time format
                vittofm

                Thank you very much for your help.

                 

                The problem is that, even if I use custom settings, I'm not allowed to use the hh.mm format. It keeps on asking me to enter the hh:mm:ss format

                • 5. Re: Problem with file time format
                  geeksharka

                  Hi again,

                   

                  I think there may be some miscommunication here. Is it possible for you to upload a sample where this error is occurring? That way we'll know exactly what the issue is, and perhaps be able to offer a real solution, and send that fixed file back to you so you can implement the fix on your solution.

                  • 6. Re: Problem with file time format
                    comment

                    vittofm wrote:

                     

                    When I update the solution, I usually create an empty file and import data

                     

                    Do you mean you save a copy as a clone? If you do, the file inherits the date and time formats of the OS where it is first opened. You should customize your OS short time format to hh.mm before cloning.

                     

                    Caveats:

                    1. I have not moved to Lion myself - the above is true in general;

                    2. I am puzzled how you managed to get Filemaker to accept hh.mm entry before - are you perhaps using comma as your decimal separator?

                     

                     

                    Note that the way you format the field to display has nothing to do with what will be accepted as valid entry.

                    • 7. Re: Problem with file time format
                      geeksharka

                      Another possible solution would be to attach a substitution script to the time field as a script trigger, and have it run OnObjectModify.

                       

                      The substitution would be to take any . and replace it on the fly with a :

                       

                      That way, when you type hh.mm -- it will automatically adjust itself to hh:mm before you leave the field.

                      • 8. Re: Problem with file time format
                        databuzz

                        I haven't got a Mac with Lion installed handy but this sounds similar to some of the known issues with FileMaker Pro v10 and Lion thought it's not explicitly mentioned in the KnowledgeBase article:

                         

                        http://help.filemaker.com/app/answers/detail/a_id/9710

                         

                        If you have a copy of FileMaker Pro v11.0v4 handy it would be interesting to see if you get the same result.

                         

                        Andrew

                         

                        FileMaker 8/9/10/11 Certified Developer

                        Databuzz

                        - - - - - - - - - - - - - - - - -

                        Phone: +61 2 9484 6565

                        Mobile: +61 418 468 103

                        Email: andrew@databuzz.com.au

                        Web: www.databuzz.com.au

                        • 9. Re: Problem with file time format
                          vittofm

                          Yes, I create a clone. And Yes, decimal separator is comme (italian format)

                           

                          I really don't know how the original file inherited the hh.mm format (when the file was first created I was using Leopard).

                          But that file worked properly on every PC or Mac I tested over the last two years, even if the file option have always been set to "use system settings".

                           

                          Two days ago, for the first time I created the clone on Lion, and the customer's PCs and Macs seemed to go crazy. My Mac Pro also did when I tested the functions related to time fields, because I enter values through scripts using combined text and date/time calculations which rely on the hh.mm format for time values.

                           

                          In the last few minutes I did the following:

                           

                          a) set international preferences with hh.mm format for short time values

                          b) created a clone

                          c) imported data from the back up

                           

                          On my Mac Pro now everything works fine.

                          Tomorrow morning (it's late night in Italy now) I'll test my customer's computers. I hope everything will go fine. I'll let you know, if you are interested.

                          • 10. Re: Problem with file time format
                            vittofm

                            Thanks Dirk, you are really nice to help me.

                             

                            In the last few minutes I did the following:

                             

                            a) set international preferences with hh.mm format for short time values

                            b) created a clone

                            c) imported data from the back up

                             

                            On my Mac Pro now everything works fine.

                            Tomorrow morning (it's late night in Italy now) I'll test my customer's computers. I hope everything will go fine. I'll let you know, if you are interested.

                            • 11. Re: Problem with file time format
                              vittofm

                              Thanks Andrew, I'll test with FM 11 asap.

                              • 12. Re: Problem with file time format
                                comment

                                vittofm wrote:

                                 

                                Yes, decimal separator is comme (italian format)

                                 

                                Ah, that figures. I suppose I couldn't get hh.mm to work because the period is reserved for fractions of second.

                                 

                                 

                                vittofm wrote:

                                 

                                Tomorrow morning (it's late night in Italy now) I'll test my customer's computers. I hope everything will go fine. I'll let you know, if you are interested.

                                 

                                Yes, of course I am interested.

                                • 13. Re: Problem with file time format
                                  geeksharka

                                  Aha, yes. Didn't realize you were not using US date/time standards. That can be an issue. Also, as databuzz pointed out, OSX Lion's first release had some issues with various characters and formatting, and this may have applied to non-US date/time formatting too. Apple subsequent OSX Lion releases have fixed all that, so if possible, make sure your client is on the latest OSX release (10.7.2).

                                   

                                  It sounds like you've got it all fixed though, so that's excellent.

                                  • 14. Re: Problem with file time format
                                    vittofm

                                    Hello there,

                                     

                                    I'm writing just to tell you that everything is fine and both Mac and Windows work.

                                     

                                    The clone created after setting international short time format to hh.mm is correctly interpreted, even with file options set to "use system settings"

                                     

                                    Thanks to everyone for your suggestions.

                                    1 2 Previous Next