4 Replies Latest reply on Feb 8, 2012 2:33 PM by MaidaSussman

    ESS with Oracle 10g and Windows 7

    MaidaSussman

      Hi Gang,

      I have a successful ESS (system DSN ODBC) connection to the Enterprise's Oracle 10g database from my server (FMS 8x on Windows Server 2000).

       

      However, I'd like to be able to work with my ESS table when doing development work on a client (FMP11, Windows 7) machine; this would require the driver/DSN be configured on the local machine. So far I've not had any joy.

       

      I've read a bit here about folks' troubles getting the DSN set up using Windows Server 2008; I suspect my problem falls into the same category. I have been sure to install/use only 32 bit drivers that I download directly from Oracle's super-excellent site. (You know, the download page that requires you to agree to the license by "selecting" a radio button that is not there--in I.E.!--and then all the text turns red and underlined? Yep, that one. Oh, oops, don't forget to sign in first! Want to get back to the same page after doing so? Good luck! Got your file downloading? Great, it's 800 MBs. See you back here in 30 minutes. Tried the "lite" version? Yep, doesn't have the drivers. Ahh.).

       

      I hope you are laughing; I am trying to keep smiling.

       

      Here's what I've tried:

      First, I tried 2 or 3 different 10g clients: a vanilla "Windows" one, the one I know works with Windows Server 2000 (XP), and one that claims to be for Windows 7 but when you try to install it it checks your OS and tells you: sorry, you're running Windows 7, and quits. (An Oracle forum poster wrote that the fix was simply to edit the (2) config files in the Oracle installer to simply include entries for Windows 7. I did this but it still wouldn't install. Even if that worked I get the feeling something else would not have.)

       

      So today being a new day I thought I'd try to install the 32 bit client for 11g, since it sounds like 11g is the only one that will work with Windows 7. It "must be" backwards compatible, right? Well it installs, so that's good, but there's no Oracle driver listed in my ODBC manager. I looked at some documentation, followed the instructions for first time use, set up the Net Configuration Manager, but still, no driver. So now I'm attempting to uninstall it, so I could start again with something else--what, I don't know. By the way it does not unistall---it encounters errors and even once I address them it doesn't go away. So now my system is a muddle.

       

      So next, I turned to my Mac (OS 10.6x). I purchased an installed the Actual Technologies' Oracle driver. I could not get the connection to work, but I haven't given up. I suspect the Oracle Connection Manager (ocm) is the problem and I will keep trying. Any thoughts from anyone using this with success for connecting to 10g would be welcome.

       

      Can anyone provide any insight about making an ODBC connection to an Oracle 10g using Windows 7?

       

      Thanks in advance.