1 2 Previous Next 23 Replies Latest reply on May 5, 2013 12:56 PM by TimGriffith

    Mountain Lion

    kaostika

      Hi, any mountain Lion users test Filemaker 11 yet.

       

      Oreste

        • 1. Re: Mountain Lion
          alfred1963

          Yes tried and failed so don't waist your time I am just restoring my MacBook back from Time-machine and no did not give up straight away it crashes on startup! would have beed nice,never mind.

           

          Well I am a sucker for updates, so I'd love to hear if somone else can make it work…

          • 2. Re: Mountain Lion
            Stephen Huston

            The main purpose of  early OS release to software developers only is so things can be cleaned up on both ends -- OS and individual applications -- so the problems are solved before a public release. Developer-Only releases, including FM Pre-Releases, aren't intended for final production work, but for readying one's self (and one's software) for the coming change.

             

            I am sure FMI is  buzzing away alrady to make sure the latest update of FileMaker WILL work with the newest OS in time for everything going public.

            • 3. Re: Mountain Lion
              canucklehead

              I just installed Mountain Lion. Now Filemaker (Advanced, version 11.0v4) is ignoring mouse clicks. I've done a Disk Repair via Recovery Disk, and repaired permissions. But the problem, as far as I can tell, is confined to my Filemaker.

              I guess it's time to buy v12.

              • 4. Re: Mountain Lion
                DavidZakary

                I took the plunge and installed it as well. No problems here with both 11.0v4 and 12v2.

                 

                You might want to try removing 11 and re-installing it. There will be issues with Mountain Lion's Gatekeeper function. There is a tech note about it.

                • 5. Re: Mountain Lion
                  canucklehead

                  Thanks David.

                   

                  What's more weird is that, right after posting my query, I discovered that a couple of my databases do respond in the normal fashion, to mouse-clicks! But most - so far - do not. I can activate a file by clicking into its title bar or status area, and the items in the status area work as usual. But I cannot activate a button, nor enter a field, nor select text, using the trackpad.

                   

                  MBPro, early 2011.

                  • 6. Re: Mountain Lion
                    robe

                    That sounds like a problem I got sometimes in Lion too with FMPA11v4. I think it has something to do with switching between windows. Have you tried changing back and fourth with different methods such as commando+tab and clicking on the window in Mission Control?

                    • 7. Re: Mountain Lion
                      jml

                      Are you using any plug-ins in those that do not work?

                      • 8. Re: Mountain Lion
                        canucklehead

                        Tried just now switching between windows, but I'm confused as to what I was supposed to be doing with that.

                         

                        In one of the misbehaving files, I switched off the 5 active plug-ins - which are not actually used in that file - causing FMPro to quit unexpectedly.

                         

                        Then, after relaunch, my databases work fine! Thanks jml.

                         

                        Is there a list of plug-ins that do/do not work, with Mountain Lion?

                        • 9. Re: Mountain Lion
                          PaulTurnbull

                          We haven't figured out why yet but the CNS Menu plugin fails on the CNSMenu_ShowMenu() call.

                          • 10. Re: Mountain Lion
                            jml

                            Haven't seen a list yet but now we now know that at least one of yours plus the CNS menu plug-ins are causing problems.  Perhaps we can create the list here if you can isolate which of the five are behaving badly.

                            • 11. Re: Mountain Lion
                              canucklehead

                              The plug-in that I re-activated first, Troi Dialog, is NOT part of the problem. Even though I have not updated it for some time.

                               

                              As for the other four, I don't think I was calling any of them in the misbehaving databases. As you know, the Plug-in Enable/Disable function in FileMaker prefs turns on/off the Plug-in globally, not for individual files. Curious that some dbs were immune to the problem.

                               

                              On testing: Reactor and Autoupdate seem okay, at least superficially.

                               

                              Enabling 2empowerFM v 2.29 reproduces the problem. As soon as I turn it on, my most-used database becomes deaf to mouse events. And 2empower Clipboard explorer v2.5, when turned on, instantly caused the database to close.

                               

                              I would go looking for updates to those 2empower plug-ins, but as I noted, I don't think I actually use them anywhere. I had merely been looknig into them a while back

                              • 12. Re: Mountain Lion
                                DavidZakary

                                When you say your database becomes "deaf" I wondering if this is what has happened to me in the past.

                                 

                                On occassion, while FileMaker is the front-most application the database windows would lose focus. They appeared as if FileMaker had been pushed to a backgroun app status - the windows go into the subdued mode.

                                 

                                If I then clicked to the Finder and the back in to FileMaker the database window would regain focus and all would be fine again.

                                 

                                I always figured it was a Mac OS "feature" and not a plugin problem. Time to go back and check.

                                 

                                This only happened with Lion I haven't had it happen with Mountain Lion (yet). I'm only a couple days into using ML. So far, no issues.

                                 

                                Dave Zakary

                                • 13. Re: Mountain Lion
                                  ch0c0halic

                                  canucklehead may not be inactivated,

                                   

                                  FMP will load any plugin in the Extensions folder. So that should you enable it it is ready for use. Just having the plugin in the FMP Extensions folder is often enough to cause problems. Inactivating the plugin is not sufficient proof that it is not the problem.

                                   

                                    • The Plugin must be completely removed from the Extensions folder(s). **

                                   

                                  BTW sometimes it an interaction between two plugins, not just a single plugin.

                                  • 14. Re: Mountain Lion
                                    Steve Wright

                                    As mentioned, I too have had a problem with v11 becoming deaf to mouse clicks, but noticed this in Lion too, not just ML.

                                    I do the same to re-activate it or close / re-open it, whichever feels right at the time

                                     

                                    Im still looking at an issue I have noticed with a runtime solution, whereby if the window is resized, the area allocated for the (disabled) scroll bars would disapear.

                                    This causes an issue with layout objects extending lower than they should which in turn makes the zoom options overlay exisiting layout elements, but a zoom in / out rectifies the problem. 

                                     

                                    For the record, the exact same solution files do not appear to have this problem when run via 11 Pro, only when running as a runtime.

                                    Other than that, it appears to be working as expected.

                                     

                                    On that note, I had always hoped that one day FileMaker would remove the scroll bars when they where not used, rather than simply disable them..maybe in 13/14

                                     

                                     

                                    Edit: Used the wrong reply button, this should have been a reply to the original poster.

                                     

                                    Steve Wright

                                    1 2 Previous Next