6 Replies Latest reply on Feb 25, 2012 10:26 AM by lietus

    No databases available

    lietus

      Hello,

       

      im very disturbed that IWP shows "No databases available" when I try to share specific database file. Google and forum search did not help at all.

      What could possibly be the source of this?

        • 1. Re: No databases available
          beverly

          troubleshooting IWP:

          1. is the web server running?

               - enter the ip / domain for the web server without the iwp link to verify

           

          2. is the test on the sample file working if using FMServerAdvanced

               - go to the page with the links to test FileMaker Server

                    http://<<ip>>:16000/test

           

          3. are you using just FileMaker Pro or FileMaker Pro Advanced?

               - are you following these steps "Sharing Your FileMaker Pro file Using Instant Web Publishing":

               - http://help.filemaker.com/app/answers/detail/a_id/5565

           

          4. have you looked at the IWP guide to verify that you have all the necessary ports open and other settings?

               - http://www.filemaker.com/support/product/docs/fms/fm11_instant_web_publish_en.pdf

           

           

          If these fail, please tell us more about your setup.

          OS? version of OS? web server? what kind of network, etc.

           

          Beverly

          • 2. Re: No databases available
            lietus

            Hi,

             

            im using FileMaker Pro with IWP through it.

             

            Strangely, now it works, but not sure for how long, all I did was selected sharing to "All users", then again to "Specify users by privilege set"

            3 days of headache..

             

            maybie FileMaker bug?

            • 3. Re: No databases available
              beverly

              lietus, usually, these are carbon-based errors.

               

              You say it "works". if the "how long" is a concern, see if there are other variables with your system. You didn't tell us the OS and/or version of OS. And you didn't tell us version of FM Pro. Hard to trouble shoot with missing info.

               

              Check "logs" (whatever for a particular OS) when it happened/happens.

               

              Beverly

              • 4. Re: No databases available
                LyndsayHowarth

                no Bug... Not strange... it was a wetware problem...

                 

                You turned on the sharing for "All users" ... by default this is not turned on and is set to none (or similar wording). This was the missing setting. With the database selected you chose to share the database and who to share it with.

                 

                It should continue to work unless you further tinker with settings

                 

                - Lyndsay

                • 5. Re: No databases available
                  lietus

                  Not sure what happens.

                  Using - FileMaker Pro 11, same DataBase won't work in IWS at Win7 and WinXP.

                  IWS page loads, but shows message "No databases available"(in place where DB name should be), no more options.

                   

                  However, problem persists, I just found workaround:

                  Switch on/off IWS, Change user access between 3 options, On/Off "Dont display IWS homepage"

                  Somehow after few retries it works again

                   

                  Problem is not in bad IWS settings, because with same settings everything works, but somehow it stops working sometimes

                  • 6. Re: No databases available
                    lietus

                    No, thats not the case. I did not tell but It worked before and after - with the same settings