5 Replies Latest reply on Feb 27, 2012 2:58 PM by edwardlscott

    Auto Complete on a hosted Solution Issue

    edwardlscott

      I'm working on a solution with a Customers table and an Apartments table. I have two layouts respectively with the "Customer Name" field and the "Apartments Name" fields on each layout, with each set to "Auto Complete from existing values" (both are fully indexed text fields).

       

      I started on the solution working locally on my machine. Then I moved the file to a remote server running FM 11 server.

       

      Now, the Customer side implementation works nicely, but the Apartments side hangs up and won't respond after entering the Apartments Name field and trying to type. When I try, I get a "command dot" cursor which then if I type <command dot> the field will enter the last single character I tried to type in (e.g., to type in "ABC" I have to type "A" then <command dot> then "B" then <command dot> then "C" then <command dot> then I can do the search on the string "ABC". Weird.

       

      I have carefully looked for any differences between the field/layout/script triggers/vallidation settings for these two implementations.

       

      Is anyone aware of any known issues related to using Auto-complete on a remotely-hosted file? Any brilliant ideas of what else I may be failing to think of?

       

      I can provide a login if anyone wants to take a look.

       

      Thanks in advace,

      Ed

        • 1. Re: Auto Complete on a hosted Solution Issue
          LyndsayHowarth

          Have a look at your File>Manage>External Data Sources

           

          I'm guessing that one is set to look at a path on your own machine rather than a relative path.

           

          - Lynday

          • 2. Re: Auto Complete on a hosted Solution Issue
            edwardlscott

            Thanks, Lynday.

             

            No, that's not it as there are no external data sources defined.

             

            Ed

            • 3. Re: Auto Complete on a hosted Solution Issue
              DavidJondreau

              I've seen this. I'm not sure how the index and the auto-complete interact (, but the issue is that auto-complete using existing values takes a while to load. It's very noticeable on a hosted field.  If you didn't escape (cmd . ) out of the auto-complete, the list would, eventually, show up.

               

              Maybe making it a value list with a drop down menu and auto-completing off that would help. Or you may have to drop the auto-complete altogether.

              • 4. Re: Auto Complete on a hosted Solution Issue
                Mike_Mitchell

                Ed -

                 

                How is the value list being built? My suspicion would be this is based on a table with a significant number of records, and each record has a fair number of fields. Here's why:

                 

                In order to build the value list, FileMaker has to load all the records in the targeted table. The entire record - all the fields - and the reason why it's slow is because you've switched from local to hosted. That means you're now contending with network bandwidth. The network payload is, if my guess is correct, what's killing you.

                 

                Possible solutions:

                 

                1) Cut back on the number of fields in the table where the value list is based. Eliminate unnecessary calculations, for example, or use 1-to-1 relationships to move less-often-used fields into a separate table.

                 

                2) See about moving to a faster network, if you can.

                 

                3) Change your drop-down to a list view. This will cause FileMaker to load only those records that are needed for display, rather than all the records in the targeted table.

                 

                Of course, this is all predicated on my being right about the situation.       

                 

                HTH

                 

                Mike


                Update: Sorry - just caught that this was auto-complete, not a value list. In that case, yes, FileMaker does have to build the auto-complete from the entire found set. So you are experiencing what I suspected - network bandwith is being choked. Option 3 will not do you any good. Sorry!

                1 of 1 people found this helpful
                • 5. Re: Auto Complete on a hosted Solution Issue
                  edwardlscott

                  David and Mike, your answers have gotten me over the hump on this one. 

                   

                  Per David's idea regarding the load time, I clicked in the field, typed a character waited about a minute or two, then the system caught up and I was able to auto complete.

                   

                  I then tried his idea of making it a value list (a "from field" list = include all values of the relevant Name field).  This accelerated how quickly it would enable the auto complete choices to appear to within an acceptable time frame. 

                   

                  Thanks for the help.

                   

                  Ed