1 2 Previous Next 21 Replies Latest reply on Mar 7, 2012 9:46 AM by timwhisenant

    FMSA11 not allowing schedule

    MattLeach

      Currently running FMSA11 on a Win 2008 Server and am trying to setup a bi-hourly backup. Server has correct date, time and time zone (EST)

       

      I've attached 2 screenshots of the issue at hand.

       

      Im trying to set the schedule to run every 2 hours from 9AM to 9PM. When i attempt to click next, the times fields turn yellow and the next button is greyed out (Screen1.png)

       

      If i set the schedule from 8AM to 8PM or any earlier, i am able to click next (Screen2.png).

       

      If i set the scheduled from 9AM to 8PM, i am also able to click next.

       

      Any idea why this may be?

        • 1. Re: FMSA11 not allowing schedule
          sicoa

          The scheduler does that when it considers it is crossing over the 00:00 hours point...i.e. You cant start at 09:00 PM and end at 09:00 AM.

           

          What locale is the server running on?

           

          Maybe this is some funky Java issue...try deleting the Java machine cache on the server...

           

          Message was edited by: Dimitris Valachis

          • 2. Re: FMSA11 not allowing schedule
            MattLeach

            I understand not running 9PM to 9AM but i am doing the exact opposite and what is really boggling me is that if i back the end time off by 1 hour, i am then able to set the schedule.

             

            The server is set to EST (Time1.png attached), System Locale is set to English

             

            I went ahead and did a reinstall of FMSA and that did not change anything, still won't set the schedule.

            • 3. Re: FMSA11 not allowing schedule
              BowdenData

              MattLeach wrote:

               

              Currently running FMSA11 on a Win 2008 Server and am trying to setup a bi-hourly backup. Server has correct date, time and time zone (EST)

               

              Im trying to set the schedule to run every 2 hours from 9AM to 9PM. When i attempt to click next, the times fields turn yellow and the next button is greyed out (Screen1.png)

               

              If i set the schedule from 8AM to 8PM or any earlier, i am able to click next (Screen2.png).

               

              If i set the scheduled from 9AM to 8PM, i am also able to click next.

               

              Any idea why this may be?

               

              Matt,

               

              Can't answer off hand, but have seen some wonkiness in the scheduler similar to this. Try setting the start date to be the next day (from the current date) and see if it helps. Try restarting the admin console (from the command line: >fmsadmin restart adminserver) and then see if you can get the schedule to cooperate. Otherwise, try deleting this schedule completely and set up a new one from scratch. I do recommend setting the start date to the next day though. Sounds crazy, but I have had this work on more than one occasion. My setup is similar to yours except Win2003 server OS.

               

              HTH.

               

              Doug de Stwolinska

              • 4. Re: FMSA11 not allowing schedule
                sicoa

                Try clearing the Java machine cache...that doesn't clear on server re-install.

                 

                I would also try accessing FMS Administration through a different machine on the network by going to http://ipaddress:16000 (or http://fullservername:16000), just to make sure it is not some sort of bizarre bug affecting the FMS Admin tool!

                • 5. Re: FMSA11 not allowing schedule
                  BowdenData

                  Thus the suggestion to set the start date to the next day. The current time on the server after 9am, so it is likely seeing the schedule as 9pm to 9am.

                   

                  HTH.

                   

                  Doug de Stwolinska

                  • 6. Re: FMSA11 not allowing schedule
                    MattLeach

                    This actually was a new scheduled that i was trying to setup. Attempted to change the start date to tomorrow but had no luck.

                     

                    Did see something that was interesting though.

                     

                    In the start time field, that time is always 3 hours behind the actual system time. I've attached a side by side comparison image showing you what i mean (Comparison.png)

                     

                    On the left is the original schedule i tried to setup and on the right is the one i just attempted. Seems that the start time is trying to go by PST which is 3 hours behind EST although at the bottom is is showing EST

                    • 7. Re: FMSA11 not allowing schedule
                      MattLeach

                      Went ahead and accessed the Admin console from another machine and now the Start Time field matches the current time, seems there may be an issue on the server with FileMaker reading the time.

                       

                      I went ahead and created the schedule from the other machine setting it from 9AM to 9PM and saved it. When i went back to the server to view the schedule i just set up, it is showing the schedule from 6AM to 6PM, WEIRD! lol

                      • 8. Re: FMSA11 not allowing schedule
                        MattLeach

                        Will flushing the Java cache affect people logged into the database?

                        • 9. Re: FMSA11 not allowing schedule
                          MattLeach

                          Will resetting the admin console affect users that are logged in?

                          • 10. Re: FMSA11 not allowing schedule
                            sicoa

                            The FM admin program is a java program that will pick up info and store settings in the JVM cache.

                             

                            So I really would look at the JVM settings and clear it's cache. Are you running the latest version of the JVM?

                            • 11. Re: FMSA11 not allowing schedule
                              MattLeach

                              According to the Java Control Panel, i'm running Version 6 Update 29 (build 1.6.0_29-b11)

                              • 12. Re: FMSA11 not allowing schedule
                                sicoa

                                What about the machine you managed to make the change from?

                                • 13. Re: FMSA11 not allowing schedule
                                  MattLeach

                                  The machine i made the change from is running Version 6 Update 22 (build 1.6.0_22b04)

                                  • 14. Re: FMSA11 not allowing schedule
                                    sicoa

                                    I would update the JVM on the server to it's latest version which I believe is Version 6 Update 31. Did you get round to clearing the JVM cache?

                                    1 2 Previous Next