14 Replies Latest reply on Mar 21, 2012 5:38 PM by BowdenData

    Error sending SMTP Mail from FMP 10 or 11

      Hi!

      Is there a way to get a more detailed level of reporting for SMTP errors.

      I have a shrink wrapped solution which can use Mail client or mail server to send emails for use in schools.

       

      Slowly over each termly updates to school IT infrastructure emails are getting harder to send.

      Our best mates at Microsoft add the paranoia confirmation box that requires each email to the mail client to be acknowledged with a "Yes I am sure I sent this" confirmation, not good when you have 200 emails to send.

      Now SMTP servers seem bound up in IP whitelists and other hurdles!

       

      I now have a school who now cannot even talk to an SMTP server.

      I am using FM 10v3 or FMAdv11 to use the single script step sending to an IP number in a field setting or manually set using SMTP server send mail

       

      All I get is error 1506 - Mail could not be sent successfully

      This does not appear immediately but takes a few seconds eg 5

      This is now a single script with a single step, no joy.

       

      The log on the SMTP server shows no activity from the Filemaker machines IP

      There are no network issues, the machines can see each other, and the school has dozens of photocopiers happily connecting through unwhitelisted IP numbers.

      A mail client from the ame machine can happily connect and send

       

      This problem is limited to the filemalker app itself (Mac and PC)

       

      Taken to my own network, the script step works.

      I have had the school IT dept working on this banging their heads on a deskworking on this but have produced no more progress (although it was fun to watch)

      My next job is to try Wireshark (packet sniffer) but that's gettinga bit deep

       

      Has anyone else seen this problem of able to offer any guidance

       

      Any help most gratefully received

       

      Best Wishes

       

      Patrick Vallely

      Skagerrak Software New Zealand

        • 1. Re: Error sending SMTP Mail from FMP 10 or 11
          Mike Duncan

          You might try to download and test with one of the plug-ins available that send email, just to give you more verbose explanation of the error you might be getting. This might help you track down what the particular issue is.

           

          I can't imagine, if regular email clients are able to send, that you can't send from FM with SMTP... there must be a setting somewhere that needs tweaked. If all that fails, you could always go through setting up your own relay or using a smtp service, but that shouldn't be necessary.

           

          --

          Mike

          • 2. Re: Error sending SMTP Mail from FMP 10 or 11
            JonA

            In my experience, the authentication settings are the most finicky. Also, depending on how the security is set up on the mail server, the "From" address may have to be a valid email address (account) in the system.

             

            Also be absolutely sure you're set to the correct port...the default is not always correct.

             

            -Jonathan

            • 3. Re: Error sending SMTP Mail from FMP 10 or 11
              usbc

              A quick test to narrow it down is to turn off  both SSL and TSL. And remember there is a difference between V10 / V11.

              I went through this in a company with a IT department. In the end they were using no encryption _within_ the local network and then relied on their server encryption beyond. The "double" encryption, so to speak, failed to cooperate.

              • 4. Re: Error sending SMTP Mail from FMP 10 or 11
                gsokolsky

                Does your mail server relay to another device (ie. a spam firewall) - if so, you may try to connect directly to the Spam firewall instead of the mail server.  I had to do this with our setup - we use First Class as our Mail Server...copiers can scan and send email just fine set up via SMTP to the mail server, but I couldn't get Filemaker to send SMTP mail until I bypassed the mail server and connected directly to our Barracuda Spam Firewall.

                • 5. Re: Error sending SMTP Mail from FMP 10 or 11

                  A local relay may be set up for testing but is out of the question for the long term due to school network security !

                   

                  Another plug in may be a possibility but It's for a shrink wrap product so I'd have to go for a dev licence, fairly pricey !

                   

                   

                  I've turned off all authentication but have actiually tried all authenticated settings too, same somewhat vague result

                  The from address IS valid for the server (I used the school technicans address, a helpful if not exasperated individual)

                  The port is set to 25, like all other devices but we did try 465. Other tests with other software  on 25 worked too.

                   

                  My big problem is that the server logs don't recognise our efforts, i don't mind errors if at least the logs give you a hint !

                   

                  The saga continues, if I get it working ... I'll be back

                   

                  Regards

                   

                  Patrick

                  • 6. Re: Error sending SMTP Mail from FMP 10 or 11

                    Hi!

                    Thanks to all for replying ! This is all good feedback!

                    I need to go look up the difference between 10 and 11, I remember it being discussed once !

                    We shouldn't need encryption as the copiers and local mail client don't use it !.

                     

                    The situation is we are connecting to a local, same subnet mail server which then points out of the school to a fibre connection with no SMTP then on to the ISP.

                    This means no way to use the ISP mail server (coming in through back end connection).

                     

                    I'll put the first class skipping idea to schhol's "head of wires" but if a local mail client can do it, how hard can/should it be !

                    Definitely worth asking though

                     

                     

                    • 7. Re: Error sending SMTP Mail from FMP 10 or 11
                      BruceHerbach

                      Hi,

                       

                      I have been through this a few times.  You don't say what type of mail server it is,  but you do say it is local.  When I have run into this,  it has usually been a Microsoft Exchange server.  The resolutions always requried the Exchange Admin and sometime the Active Directory admin to authorize the specific computer to be able to send using SMTP.    This was in addition to the the users Outlook e-mail program that worked without any unusual intervention.  Sorry I don't know what setting were required but it did require the PCs IP address. 

                       

                      In a recent instance,  I set up an account on Gmail to send the e-mail and buried the access in the database.  This worked,  I did have to throttle the sending.  Gmail

                      doesn't like large batches of e-mails.  They shut you down,  thinking that it is some form of Bot sending.

                       

                      HTH

                      Bruce

                      • 8. Re: Error sending SMTP Mail from FMP 10 or 11

                        Thanks Bruce !

                        I'll pass that to the school admin just in case we'r missing something !

                        ta !

                         

                        Best wishes

                         

                        Patrick

                         

                        ===================================================

                          Patrick Vallely     021 906 676               

                          Skagerrak Software,                           

                          Accommodation Administration Software         

                          PO Box 56-710 Dominion Road, Auckland NZ        

                          http://www.motelmate.co.nz                      

                        ===================================================

                        • 9. Re: Error sending SMTP Mail from FMP 10 or 11

                          This just in.............

                           

                          "We are using Windows Server 2008 SR2 with Exchange 2010 Sp1.

                          On the Exchange server we have setup a relay to port 25.

                           

                          This is setup to send email without need authentication.

                          We are using about 25 Photocopiers and other devices using 172.16.0.19 port 25 on basic  smtp and it works fine.

                           

                          When we sent the email from any of the computers using Filemaker it would just say could not send.

                           

                          We could not find any information to provide from the Exchange server to suggest it even left the machine in the log files. We could send emails fine on the same machine to smtp from other software eg Outlook express."

                           

                          I am unfamiliar with Exchange so have nowhere to go on problems with this server

                           

                          I think I've tried the Gmail route before, it close you down fairly quickly !

                          (Bah humbug!)


                          • 10. Re: Error sending SMTP Mail from FMP 10 or 11
                            BruceHerbach

                            Hi,

                             

                            You might take a look at the Microsoft site and see if they have any

                            advice on this.  I did this for a company a few years ago,  and

                            Exchange/Active Directory required the IP address of the computer and

                            possibly some additional information to accept/send SMTP mail from an

                            application like FileMaker.  We also had printers/copies that would send

                            e-mails.  These were internal e-mails only so Exchange let them through

                            to local accounts.  they couldn't send outside the company.  My guess is

                            this is what you are running into.  When I did this we had a couple of

                            very good/knowledgeable Exchange and Active Directory Admins.  Even so

                            it took them a couple of days/attempts before getting this to work.

                             

                            As far as Gmail is concerned,  so far I have been able to use it.  The

                            key has been to limit the number of e-mails being sent at any one time. 

                            Once I get up over 100,  I believe that you are at risk of being shut

                            down.  Of course breaking the list up into smaller chunks and delaying X

                            minutes between each batch of e-mails to send can be a pain in the neck.

                             

                            HTH

                            Bruce

                             

                             

                            • 11. Re: Error sending SMTP Mail from FMP 10 or 11

                              Thanks  Bruce !

                              We'll have a go at that today! 

                               

                              Cheers

                               

                              Patrick

                              • 12. Re: Error sending SMTP Mail from FMP 10 or 11
                                ouidamac

                                Are the email addresses used from Contact or Address Book? "In Windows, SMTP mail fails to send when the recipients email address is obtained from Contacts or Address Book. This issue has been confirmed with Windows (Vista) Mail and Outlook Express." resulting in this error. See this FileMaker article ~ http://help.filemaker.com/app/answers/detail/a_id/7083/related/1

                                • 13. Re: Error sending SMTP Mail from FMP 10 or 11
                                  ouidamac

                                  Also, if you have access to the FileMaker Server Admin Console, go to Create a Schedule (or select an existing Backup Schedule you would be willing to run). When you get to "Enable email notifications" step 7 (of 8) in the Schedule Assistant window enter your SMTP info here, enable Email Notifications and run the script. If this is successful then you know that FileMaker itself does not have a problem with the SMTP credentials and you can determine that the error is more specific to the send SMTP mail script step and more likely to be a client-side problem than a FileMaker Server-side issue. I hope you find this helpful.

                                  • 14. Re: Error sending SMTP Mail from FMP 10 or 11
                                    BowdenData

                                    skagpatrick wrote:

                                     

                                    Is there a way to get a more detailed level of reporting for SMTP errors... All I get is error 1506  - Mail could not be sent successfully.

                                     

                                     

                                    Patrick,

                                     

                                    Try the mail tool from SavvyData. It is designed specifically for these kinds of issues. It basically iterates through a whole bunch of variations for configuring SMTP email and reports which one works.

                                     

                                    http://www.savvydata.com/blog/2009/11/fixing-smtp-send-mail-error-1506/

                                     

                                    I have used it numerous times with good success.

                                     

                                    HTH.

                                     

                                    Doug de Stwolinska

                                    Bowden Data Services, LLC