3 Replies Latest reply on Mar 26, 2012 7:30 PM by LyndsayHowarth

    FM 8.5 (trouble getting IWP working)

    fozzy

      Hello,

       

      I wonder if anyone has run into this... I've been running a FM 8.5 database on a Network and allowing people to edit using Internet Web Publishing for years now and only encountered a problem when I moved the file from the old machine to the new machine earlier today. Now when I try to activate Internet Web Publishing Filemaker gives me a message that "Filemaker cannot share files over the web because Instant Web Publishing could not be started". This message comes up in a dialog box the moment I click the "on" radio button on the Instant Web Publishing window.

       

      IT is always 'improving' things around here. I suspect our newer machines are equipped with features that disable anything usefull like this in order to make it harder to get anything done... Does anybody have any ideas as to what that might be? A Control Panel setting perhaps???

       

      Thanks,

       

      - Dave

       

      PS. Please forgive if this doesn't exactly fit the subject of this Discussion Forum. This is my first post and when I started writing it looked fairly close... Now that I'm nearly done I'm not so sure it fits that well...

        • 1. Re: FM 8.5 (trouble getting IWP working)
          LyndsayHowarth

          HI Dave,

           

          IWP uses Port 80 by default. If something else on the machine is using Port 80 (ie web hosting) then you will get this message. You can, as an alternative host the files out of Port 591... there will be no clash with this and you set it in FileMaker preferences. The port will have to be added to the URL like this:

          http://yourIPorDomain:591/fmi/iwp

           

          You say nothing about which OS you are using... if you did I might have had a better idea on how to advise you.

           

          - Lyndsay

          • 2. Re: FM 8.5 (trouble getting IWP working)
            fozzy

            Hi Lyndsay,

             

            Sorry for the obvious oversight on my part. We're still using XP Professional 2002 Service Pack 3 here.

             

            I took a look for a place in Preferences where one could specify a Port and don't see one. In the meantime I compared the FM program files on the C Drive of my old machine with those on the new machine. At least at the top level the two match so its not a case of IWP not being included as part of the download (assuming that the IWP stuff would be located in the C:\Program Files\FileMaker\FileMaker Pro 8.5 Advanced folder). Working from memory here but I seem to recall having to click Web Publishing as a Plugin on the Preferences tab in order to get it working originally way back when. It does not seem to be there on either my old or new machines now.

             

            I also tried making a new database on the new machine and ran into the same problem when trying to Web Publish it. I was able though to create a new database on the old machine which is currently hooked up to the very same network as the new one and was able to publish it without problem.

             

            So from what I can tell the only difference between the two machines is that the old one allows for the "On" radiobutton to be activated when clicked on the "Instant Web Publishing" window. Interestingly, that window opens with "<none>" in the area beside where it says "URL:". That area is grey howover and cannot be edited.

             

            - Dave

            • 3. Re: FM 8.5 (trouble getting IWP working)
              LyndsayHowarth

              Web support when installed is in the C:\Program Files\FileMaker\FileMaker Pro 8.5 Advanced/Extension folder.

               

              Try turning off the IIs web server on the XP machine... then see if the IWP works.

               

              When you choose File>sharing>IWP... there is a button for Advanced options where you can change the port to 591 or swap it back to 80. It is in sharing that you turn IWP on for the machine and nominate which databases are being shared to whom.

               

              - Lyndsay