6 Replies Latest reply on Apr 10, 2012 8:13 PM by taylorsharpe

    FMPA12 Crashes on start

    taylorsharpe

      I have a development machine with FMPA11 and FMSA11 working just great. I installed FMPA12. I then uninstalled FMSA11. I installed FMSA12 and it didn't work because I failed to rename the log files. So I stopped at this point and uninstalled FMSA12. I then opened FMPA12 to start converting the databases before reinstalling FPSA12. But to my surprise, FMPA12 won't open on my Mac without crashing. It crashes on startup.

       

      I'm running a Mac Pro OS X Server version 10.7.3 with two 3-GHz Quad-Core Intel Xeon cpus, 8 Gigs of RAM, which was made in early 2008 and is running two 30 inch monitors.

       

      Well, I obviously won't go to my clients to do this tomorrow... so cancelling the FileMaker 12 upgrades. Bummer. Anyone have any suggestions?

       

      Here is what I get on startup in the crash screen (I only included the header part and not the whole crash log):

       

      Process: FileMaker Pro [1128]

      Path: /Users/USER/*/FileMaker Pro Advanced.app/Contents/MacOS/FileMaker Pro

      Identifier: com.filemaker.client.advanced12

      Version: 12.0.1 (12.0.1)

      Code Type: X86 (Native)

      Parent Process: launchd [262]

       

       

      Date/Time: 2012-04-05 23:21:41.577 -0500

      OS Version: Mac OS X Server 10.7.3 (11D50b)

      Report Version: 9

       

       

      Interval Since Last Report: 437950 sec

      Crashes Since Last Report: 5

      Per-App Interval Since Last Report: 28 sec

      Per-App Crashes Since Last Report: 5

      Anonymous UUID: 5D009B0C-0F54-4288-9F72-E4603B837FED

       

       

      Crashed Thread: 0 Dispatch queue: com.apple.main-thread

       

       

      Exception Type: EXC_BAD_ACCESS (SIGBUS)

      Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000004

       

       

      VM Regions Near 0x4:

      --> __PAGEZERO 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL /Users/USER/*/FileMaker Pro Advanced.app/Contents/MacOS/FileMaker Pro

      __TEXT 0000000000001000-0000000000af8000 [ 11.0M] r-x/rwx SM=COW /Users/USER/*/FileMaker Pro Advanced.app/Contents/MacOS/FileMaker Pro

       

       

      Application Specific Information:

      objc[1128]: garbage collection is OFF

       

      Java information:

      Exception type: Bus Error (0xa) at pc=000000000007c835

       

      Java VM: Java HotSpot(TM) Client VM (20.6-b01-413 mixed mode macosx-x86)

       

      Current thread (00000000258ec400): JavaThread "Thread-1" daemon [_thread_in_native, id=-1396219200, stack(00000000bf800000,00000000c0000000)]

      Stack: [00000000bf800000,00000000c0000000]

       

      Java Threads: ( => current thread )

      00000000268ef400 JavaThread "Timer-0" daemon [_thread_blocked, id=-1335808000, stack(00000000b0513000,00000000b0613000)]

      00000000268ec400 JavaThread "Poller SunPKCS11-Darwin" daemon [_thread_blocked, id=-1336864768, stack(00000000b0411000,00000000b0511000)]

      =>00000000258ec400 JavaThread "Thread-1" daemon [_thread_in_native, id=-1396219200, stack(00000000bf800000,00000000c0000000)]

      0000000016ac5000 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=-1309446144, stack(00000000b1e37000,00000000b1f37000)]

      0000000016ac4000 JavaThread "C1 CompilerThread0" daemon [_thread_blocked, id=-1310502912, stack(00000000b1d35000,00000000b1e35000)]

      0000000016ac3000 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=-1311559680, stack(00000000b1c33000,00000000b1d33000)]

      0000000016ac2000 JavaThread "Surrogate Locker Thread (Concurrent GC)" daemon [_thread_blocked, id=-1312616448, stack(00000000b1b31000,00000000b1c31000)]

      0000000016aba400 JavaThread "Finalizer" daemon [_thread_blocked, id=-1313673216, stack(00000000b1a2f000,00000000b1b2f000)]

      0000000016ab9400 JavaThread "Reference Handler" daemon [_thread_blocked, id=-1314729984, stack(00000000b192d000,00000000b1a2d000)]

      Other Threads:

      0000000016ab6800 VMThread [stack: 00000000b182b000,00000000b192b000] [id=-1315786752]

      0000000016ac0400 WatcherThread [stack: 00000000b1f39000,00000000b2039000] [id=-1308389376]

       

      VM state:not at safepoint (normal execution)

      VM Mutex/Monitor currently owned by a thread: None

       

      Heap

      par new generation total 14784K, used 5715K [0000000019cc0000, 000000001acc0000, 000000001acc0000)

      eden space 13184K, 43% used [0000000019cc0000, 000000001a254f48, 000000001a9a0000)

      from space 1600K, 0% used [000000001a9a0000, 000000001a9a0000, 000000001ab30000)

      to space 1600K, 0% used [000000001ab30000, 000000001ab30000, 000000001acc0000)

      concurrent mark-sweep generation total 49152K, used 0K [000000001acc0000, 000000001dcc0000, 000000001fcc0000)

      concurrent-mark-sweep perm gen total 12288K, used 5553K [000000001fcc0000, 00000000208c0000, 0000000023cc0000)

       

      Code Cache [0000000017101000, 00000000171aa000, 0000000019101000)

      total_blobs=262 nmethods=117 adapters=89 free_code_cache=32872704 largest_free_block=0

       

      Virtual Machine Arguments:

      JVM Args: -Xbootclasspath/a:/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/deploy.jar:/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/plugin.jar:/Library/Java/Home/lib/deploy.jar:/Library/Java/Home/lib/plugin.jar:/Library/Java/Home/lib/jaws.jar -Djava.ext.dirs=/System/Library/Java/Extensions:/Library/Java/Home/lib/ext:/Library/Java/Extensions -Dcom.apple.eawt.CocoaComponent.CompatibilityMode=false -Dsun.reflect.noInflation=true

      Java Command: <unknown>

      Launcher Type: generic

      Physical Memory: Page Size = 4k, Total = 8192M, Free = 1548M

        • 1. Re: FMPA12 Crashes on start
          RonSmithMD

          You should have uninstalled Server 11 FIRST. Uninstall everything (11 and 12) and start fresh with 12.

           

          Ron

           

          Ron Smith, MD

          ron@ronsmithmd.com

          • 2. Re: FMPA12 Crashes on start
            taylorsharpe

            I did unintsall 11  Server first. The only error I missed in following the instructions was that I did not rename the log files.  So I uninstalled 12 Server after it failed to install correctly and reinstalled it.  Now it won't boot the admin web page and when I go to the Mac OS X Server tool, the Web Server section shows "Error Reading Settings".  It will serve a web page, but not the FM Admin web page on port 16000. 

             

            But if you read my message above, the Server was not what I am having problems crashing.  It is FileMake Pro Advanced that is crashing. 

            • 3. Re: FMPA12 Crashes on start
              taylorsharpe

              Oh, one more thing, I followed the FM instructions of not uninstalling FMPA11 and that is why I did not remove it first.  It is apart their instructions for installing FMPA12 and that is why I did not uninstall FMPA11 first.  I only uninstalled FMSA11 and I did it before I installed FMSA12. 

              • 4. Re: FMPA12 Crashes on start
                RonSmithMD

                Your initial post did say that you installed FMPA12. Sorry, my mistake there. If FMSA is not reading your settings files, then they are either locked, have the wrong permissions/ownership, or wrong folder permissions/ownership. At any rate, that could still be the reason that FMPA won't open a file on the server. Its a red flag that there are more things wrong.

                 

                I would move that entire log folder out and still do a fresh install of FMS12. Rename the current FMPA folder in the applications folder or even better delete it, and do a fresh install. Don't forget to include plugins that you need if any.

                 

                Make sure you run Software Update and get the latest Java as well. This was a problem on my OS X Server install, and I resolved that issue. Before installing anything too remember to STOP the database server and make sure that it is not set to restart on reboot. Once you uninstall, remember to REBOOT BEFORE you reinstall as well. That specifically was my problem in fact I believe.

                 

                Ron Smith, MD

                ron@ronsmithmd.com

                • 5. Re: FMPA12 Crashes on start
                  taylorsharpe

                  After my first failure at FMSA12, I ran the Mac OS X Software updater and there was a JAVA update and I ran it.  So I don't know if having the old JAVA was a problem with the FMSA12 install.  If course after our past histories with JAVA and Admin console, I'm always leery about JAVA. 

                   

                  I've erased the FPA12 folder and reinstalled it to no avail. 

                   

                  So, I'm doing a Time Machine backup to a time before I did any 12 stuff and after it restores, I'll do the JAVA update.  Then I'll install FMPA12 and see if it works before I try any FMS stuff.  Then if FMPA12 works, I'll proceed with the FMSA install. 

                   

                  If thta doesn't work, I'll do a restore of Mac OS X server and work from a clean copy, but that sure is a pain and I hope I don't have to do that. 

                   

                  I'll have to finish this later today since I have to go off to a client now.  I'll let you know how it goes and thanks for some input. 

                  • 6. Re: FMPA12 Crashes on start
                    taylorsharpe

                    FYI, apparently the Mac OS X user account I was using was not liked by FMPA or FMSA.  I created another account and could installed FMPA12 just fine, but not FMSA12.  I resintalled Mac OS X Server TWICE to no avail.  So I then wiped the drive and did a clean Mac OS X Server 10.7.3 install.  After doing this, I was able to install both FMPA12 and FMSA12.  I don't know if this was a problem with the OS or FileMaker, but it is resolved.  However, reconfiguring a server is not exactly a fun process including setting up accounts, web pages, DNSs, etc.  Since I don't see other people reporting, this, I'm assuming it was a problem in my system and not a FileMaker bug.  At least I'm up and running and life is good for now!