2 Replies Latest reply on Apr 18, 2012 5:39 PM by AussieMT

    Windows & Server 11 & PHP

    AussieMT

      Environment

      Windows Server 2008 R2 Standard

      IIS 7.5

      FMSA 11.0.3.309

      PHP site assistant installed

       

      Issues

      On installation went for defaults

       

      Using PHP site assistant I am able to configure CWP, and can access webpages via server IP address internally via http://10.0.23.4

      BUT this seems to only remain active for short period of time.

      Set it up last week, confirmed working, returned today and get the following message:

       

      401 - Unauthorized: Access is denied due to invalid credentials.

      You do not have permission to view this directory or page using the credentials that you supplied.

       

      I returned to PHP site assistant, and get:

      The following error occurred when opening the project file:

      Could not establish a connection with the server.

       

      Not sure where to start solving this puzzle.

      Is it an IIS issue?

      or FMSA?

       

      I think I need help from a windows FMP developer/guru.

       

      Michael T

        • 1. Re: Windows & Server 11 & PHP
          databuzz

          Hi Michael,

           

          I would check the basics first and ensure that (using the FileMaker Server Admin Console) Web Publishing is enabled and running and that you have the green lights in the overview section for the web server and php. Finally check that the account you are logging in with has the php extended privilege in the associated Privilege Set.

           

          HTH,

          Andrew

           

          FileMaker 8/9/10/11 Certified Developer

          Databuzz

          - - - - - - - - - - - - - - - - -

          Phone: +61 2 9484 6565

          Mobile: +61 418 468 103

          Email: andrew@databuzz.com.au

          http://www.databuzz.com.au

          • 2. Re: Windows & Server 11 & PHP
            AussieMT

            Andrew,

            Thanks so far.

            1 Bit the bullet and reinstalled IIS, restarted server a couple of times.

            2 Now IIS default page appears.

            3 added code on IIS default page to point to required home page

            4 now to get it visible to outside world

             

            Michael T