1 2 3 Previous Next 32 Replies Latest reply on Oct 19, 2012 8:53 PM by sastickf

    FMp advanced v12.0v1 - locking up

    peternew

      I'm a v-e-r-y unhappy camper!

       

      I'm a FileMaker developer with over 20 years experience dating back to ver 1.0..

       

      I've downloaded and installed FMp Advanced ver 12.0v1. The install is stock standard - no additional extensions. I'm running a MacBook pro with MacOS 10.7.3 with 4gb RAM.

      The error occurs with the included FileMaker Templates, files I have upgraded from FMpA v11.x, commercial file[s] which claim FMp v12 compatability, and test files I have written from scratch myself.

       

      FileMaker 12 runs for about 30 minutes while I do a variety of things including making new fields, editing and creating layouts and/or simply using a solution...then suddenly many of the menu items are greyed out and cannot be selected. Scripts do not respond and I get a simple 'clicking' sound when trying to access any script either on a layout or in Script Maker. The 'Quit" command is greyed out and nothing I have been able to find will restore basic functionality. The only recourse is to do a Force Quit and restart FileMaker.

       

      As a developer this is becoming extremely frustrating and I'm concerned that the same 'problem' may translate to client solutions.

       

      I've used Goya's Base Elements [the new ver 12 iteration] but cannot see any obvious problem[s].

       

      There doesn't seem to be any discussion on the web so maybe it's just me...but I hope not!

       

      I am aware of, and have corrected, the problem where the ver 12 installer leaves old extensions in the Library - I've removed them but to no avail.

       

      Given the level of FileMaker support in the past I'm not hopeful....but I need to vent my frustration in the hope that somebody may be able to suggest solution or be able to point out where I have erred!

        • 1. Re: FMp advanced v12.0v1 - locking up
          melastudio

          I try with a simple suggestion.

          The issue you explain seems similar to what happens when you use modal windows.
          So if you have changed the behaviour of some window, disabling the closing botton of the OS, without providing an interface botton to close the window... then you know what you have to do

           

          Otherwise, ignore my post!

          By

          • 2. Re: FMp advanced v12.0v1 - locking up
            cortical

            Just a guess.

             

            What does Activity Monitor show?  I had a period about 6 months ago, FM11A, OSX 10.5.8 with >100% CPU  FM  anomalies, and similar sounding lack of response.

             

            Through the haze of distance, it may have been a font based issue; dump FM preferences...

             

            On the rare occasions when aberrations occur, using something like Onyx (Titnanium software) to flush every cache , particluary system caches, can resolve issues like this.

            • 3. Re: FMp advanced v12.0v1 - locking up
              gcatnine

              I had several signals about realiability and performance of FMv12.

               

              i.e. look at my post: http://forums.filemaker.com/posts/b9b2b439d9

               

              one question: are you using the server or just FMpA?

               

              that becasue I have installed the server on my pc, but I gave too much memory to FMS and I got symptoms similar to yours.

              • 4. Re: FMp advanced v12.0v1 - locking up
                technet_admin

                Are you perhaps using Mission Control with multiple spaces/desktops? I had it happen when a modal dialog from FMP and other Mac applications as well will appear in a different space than the main application, making it appear that the app is locked up. Once I find and dismiss the modal dialog in the other space, then all is well again. HTH.

                 

                Best,

                Dave

                • 5. Re: FMp advanced v12.0v1 - locking up
                  peternew

                  Thanks for the thought, 

                  The Activity Monitor also seems to get caught in the problem and is complete unresponsive ... and FMpA 12 does not seem to generat  an error log for this.

                  I dumped all Preferences and apart from starting faster FMpA 12 still exhibits the same problem I've also tried Onyx..but to no avail.

                  • 6. Re: FMp advanced v12.0v1 - locking up
                    peternew

                    Thanks for the reply,

                     

                    I've read your post and seen the frustration - I can't reliably reproduce the problem either but it is still there and seemingl random.

                      I'm running FMpA 12 locally - I have Server but am not using it yet - need to get this abberation settled first.

                    • 7. Re: FMp advanced v12.0v1 - locking up
                      peternew

                      Thanks for the toughts...but...no... Mission Control is just sitting there...I'm not particularly using it.

                       

                      I've checked for modal dialogues and Script Debugger for running scripts of any sort...again...no luck.

                      • 8. Re: FMp advanced v12.0v1 - locking up
                        tech_liaison

                        Okay, have you tried removing all plug-ins from FileMaker's Extensions directory, and also any that may be installed in your home directory at, ~/Library/Application Support/FileMaker/Extensions/, and then trying to reproduce the problem with no plug-ins installed?

                         

                        Best,

                        Dave

                        • 9. Re: FMp advanced v12.0v1 - locking up
                          peternew

                          Dave,

                           

                          Thanks...but...yes....I originally encountered the problem with a completely clean install of FMpA 12 and a clean out of ~/Library/Application Support/FileMaker/Extensions/. It was at this point that the problem manifested itself - within an hour of installing FMpA 12. Even now I have only installed an extension as needed - Goya's Basic Elements - and then removed it after I had done the analysis. Frustrating not being able to use the couple more that I have come to rely on but until I can solve this problem I'm not quite game to. Other programs running on the Mac - yes - but no change from previously and even if I stop them all loading the problem still occurs.

                           

                          The lockup/crash seems to be confined to layout mode while I am working at that level. Yesterday I changed the order of a TAB group and it locked/crashed while writing back the change. With a bit more looking under my belt it is beginning to seem that the problem mainly occurs when writing back some change within Layout mode. I get the beach ball of forever for about 30 secs then a complete crash. Often whileI am doing something it becomes unresponsive and if I check the 'Quit' comman is greyed out and most functions are either greayed out or do not respond. This is followed after a moment or so by the beach ball and then the crash.

                          To date it has not happened when just using the program in Browse mode.

                           

                          Cheers,

                          PeterN

                          • 10. Re: FMp advanced v12.0v1 - locking up
                            Stephen Huston

                            Has this been happening on a specific layout, or, if more than one, do they have anything in common such as an added non-FM-native graphic?

                             

                            If this is only happening in layout mode, you may have a problem with a specific layout or a specific object being used one some layouts, or even a specific type of object on layouts.

                            • 11. Re: FMp advanced v12.0v1 - locking up
                              peternew

                              Thanks for the thoughts - but - unfortunately, no. It seems to happen on any layout but only while editing. Good thought on a specific layout but it seems to be happening on various layouts at the moment however I can check this aspect, although it will take some time. I've just made some notes on the latest episode which is a slightly different action...

                              FMp12A crash - have just come out of Layout mode - edited a script - tried to run a different script and got no result - checked FMpA menu and 'Quit.." is greyed out. Main window shows title of 'Searching...' Script debugger does not show any scripts running. Have let it run for over 5 mins but will now have to Force Quit simply to get on with the job.

                              ...I made these notes about 10 minutes ago.

                               

                              Thanks,   PeterN

                              • 12. Re: FMp advanced v12.0v1 - locking up
                                cortical

                                Layout mode rings a bell for me too, when this was happening late last year (?) with FM11A v4 on OS 10.6.8

                                 

                                I do not routinely run plugins ( other than the default autoupdate )

                                 

                                And as you say, for you  it was happening on a clean insatll of FM

                                 

                                One other thing that is lurking in the memory (mine), was resetting the file cache size in FM prefs. Set to default , quit, restart OS, ...I also noticed a big change in quit time, which had been annoyingly slow.

                                 

                                Mine is back at 256MB, and no issues since the hang problem went away.

                                • 13. Re: FMp advanced v12.0v1 - locking up
                                  DaveRawcliffe

                                  I don't know if this is gemain or not. But, it sure sounds similar to my post:

                                   

                                  "FMA not responding"

                                   

                                  That thread got convoluted and was never answered.

                                  When I wrote it, it was for FMA 11. I had the "Force Quit Applications" (FQA) window open.

                                   

                                  Points 1 & 2 set up the various conditions that caused FQA's FileMaker "Not Responding".

                                  Point 3 was the result. Not Responding would cycle depending on the status of the spinning Pizza.

                                   

                                  I let this run to completion to see if it would resolve and yes it would. Some times it took up to a 1/2 hour to regain control.

                                   

                                  That said, try this with "Force Quit Applications" open and see if you get the same result in FMA 12.

                                   

                                  Just a train of thought.

                                  Dave

                                  • 14. Re: FMp advanced v12.0v1 - locking up

                                    This may not even be a FileMaker problem but one of OS X.

                                     

                                    If this lockup happens, I switch to a different application (even Finder does it) via cmd-tab and then click into a FileMaker window again, which then works as expected.

                                     

                                     

                                    Winfried

                                     

                                    --

                                    Check out FMDiff to compare two FileMaker files and test for file corruption at <http://www.fmdiff.com

                                    1 2 3 Previous Next