3 Replies Latest reply on Apr 30, 2012 11:50 PM by AvdBroek

    Important feature lost in FMgo 12

    AvdBroek

      Hi all,

       

      In FMgo 1.2 we got a very nice feature to update a local fmp7-file on a iOS-device. From the local file on the iOS-device we could start a script that is located on the server. We could check if there is a new version and download that new version from a container field with the script step 'Export Field Contents'. It worked very nice. After exporting the field content from the server to the iOS-device we only had to close the fp7 file and manually open it again. Now we're in the new file. Great!

       

      In FMgo 12 this doesn't work any more. The script step 'Export Field Contents' now results in a 20402 'no permission' error. It seems to be that we have 'no permission' to overwrite the file that is currently open. I do understand this, but: in FMgo 1.2 it worked and it was such a nice feature. And that is not all: after the 20402 error we are in trouble because we're left behind with a corrupt file on the iOS-device.

       

      I tried to close the local file first before exporting the field contents as part of the script on the server. But this doesn't work either. The file is nog closed and the error remains. When the local file is not open and I try to manually export the field content it all works fine. The local file is overwritten and the new version is available. But this is not what I'm looking for because now the user has to login to the server manually. It can no longer be part of a automated script on the iOS-device.

       

      Now my question is: Is there an other way to automatically update a local file on the iOS device without complicated user actions? The only thing I want for the user is to get a message that a new version is available and the option to start downloading now or to download it later.

       

      Hope someone can help me.

       

      AB