AnsweredAssumed Answered

Problem with native applescript running in Filemaker 12

Question asked by tschultz on May 3, 2012
Latest reply on May 26, 2012 by sporobolus

I've used a particular native script running under various versions of Filemaker. When I upgraded to v. 12, I started experiencing a curious problem.

 

I developed a FM script that runs in a file hosted on a network. I run FM Pro Advanced and the other users have Filemaker Pro. The Applescript script says "tell application Filemaker Pro" when they are the users and "tell application Filemaker Pro Advanced" when I am the user.

 

I recently tried to alter the script for a Filemaker Pro user and kept getting an error message saying "Expected end of line but found class name." The highlight stopped on the word "record" at the end of this line--tell current record. I could not click on OK without receiving the error message.

 

If I change the "tell application..." line to "tell application Filemaker Pro Advanced," I can click OK and save the FM script. The problem is that when the script is triggered on a machine that only has FMP it tries to find that app and I get an error. As soon as I remove "Advanced" from the Applescript, I get the error.

 

Again, everything worked fine under Filemaker 10 and 11. I'm not an expert with Applescript. Any help would be appreciated.

 

Thanks much.

Outcomes