4 Replies Latest reply on May 13, 2012 8:15 PM by harringg

    Sync FM Go and FMP 12

    harringg

      I'm really trying to keep this as simple as possible just to see if I can get it to work. I have asked in several places on the FMP forums how to mimic Bento's syncing, update a record on my iOS when away from my home network, and sync and it updates the records in my desktop app when I get back home. I'm told to use port forwarding, keep my desktop app (which is on a laptop that isn't always on), and "use a script", but no further specifics.


      I'm following the directions in this PDF: http://www.filemaker.com/support/product/docs/filemaker-go/fmgo_development.pdf (Pages 7 and 8). I know this question relates to getting records from the desktop (Examle 1: 1-6), but again, just trying to do it systematically. Once it's working, I'll continue on with pushing from iPad to desktop (Example 2: 1-6)

       

      Here are my notes as recorded following the steps. Clearly I'm missing something, have something configured wrong, or the instructions aren't clear. I'm running FMP 12 on 10.7.4 and FileMaker Go 12 on the iPad 2 (wi-fi only)

       

      New File:

      aSource.fmp12

      Field1:Name

      Field2:Cost

      File>Sharing>FileMaker Network>On>All Users>10.0.1.11

       

      New File:

      aTarget.fmp12

      Field1:Name

      Field2:Cost

      File>Sharing>FileMaker Network>On>All Users>10.0.1.11

       

       

      aTarget.fmp12

      Scripts>Manage Scripts>New (Import From Remote)

      Import Records (double-click)

      fmnet:/10.0.1.11/aSource.fmp12

      Perform without dialog (check)

      Specify (Click)

      Name-->Name

      Cost-->Cost

      Add New Records (only option, everything else is greyed out)

      OK

      Results in:

      Import Records [No Dialog; "aSource.fmp12"; Add; Mac Roman]

      Save

       

      Close aTarget.fmp12

       

      Email aTarget.fmp12 to iPad

       

       

      Open aTarget.fmp12 on iPad

      Add record in aSource.fmp12 (in FMP 12, desktop app), Joe, 1

      Run Script on iPad (Updates records on iPad to Joe, 1)

      Run Script again on iPad (Updates records on iPad to Joe, 1, Joe, 1) This is not what I want! I know why it's happening, the script is "Add" only, but why not the Update option as in the PDF?

       

       

      Add record in aSource.fmp12, Jane, 2, John, 3

      Run Script on iPad

      (Updates records on iPad to Joe, 1, Joe, 1, Joe, 1, Jane, 2, John, 3)


      So it's keeping the first two Joe, 1 records and now adding the new ones (Jane, 2, John, 3)

       

      Any guideance would be appreciated.

        • 1. Re: Sync FM Go and FMP 12
          harringg

          I tried the second part of the instructions in Example 2: 1-6.  I've got iOS 5.1 (and 6.5 GB available) on the iPad 2.  Go_iPad 12.0.2.  Files>Files on Device> FileMaker shows bSource, but not bTarget.

           

          ----

          New File:

          bSource.fmp12

          Field1:Name

          Field2:Cost

          File>Sharing>FileMaker Network>On>All Users>10.0.1.11

           

           

          bTarget.fmp12

          Field1:Name

          Field2:Cost

          File>Sharing>FileMaker Network>On>All Users>10.0.1.11

           

           

          Close bSource.fmp12

          Email bSource.fmp12 to iPad

          Open in FM Go

           

           

          Edit bTarget.fmp12 on Desktop

          Scripts>Manage Scripts>New (Import To Remote)

          Set Variable (double-click)

                    Name:$FilePath

                    Value: Get(DocumentsPath) & "bSource.fmp12"

          Import Records (double-click)

          file:$FilePath

          file:bSource.fmp12

          Perform without dialog (check)

          Specify (Click)

          Name->Name

          Cost->Cost

          Add New Records (only option)

          SAVE

           

          Close bTarget.fmp12

           

          Email bTarget.fmp12 to iPad

           

          Open bTarget.fmp12 in iPad

          (bSource.fmp12 is already open and bTarget.fmp12 isn't opening on iPad, even though Open in FileMaker Go is selected from email attachment)

          • 2. Re: Sync FM Go and FMP 12
            DavidJondreau

            The Import[] option to "Update matching" is only enabled when there are records in the target file when you're writing the script.

            1 of 1 people found this helpful
            • 3. Re: Sync FM Go and FMP 12
              harringg

              Thank you.  That has my "offline" (located on iPad) database pulling data from the desktop when I'm back on the wi-fi network.

               

              I'm still not getting the data entered "offline" to push to the desktop.

               

              One thing I'm seeing that is confusing is this:

              Email bTarget.fmp12 to iPad, open in FM Go.  It's not there.  Quit FM Go and relaunch and it shows up as

              FM Go>Files>bTarget-2


              Do I have a corrupted file/FM Go install?  I've just deleted the app on the iPad, and am trying to re-install it just sits there saying "Waiting..." and my wi-fi is on. I can view sites in Safari, maybe App Store is having issues right now too.  I've powered down the iPad and back on too, no luck with FM Go install.  I even tried downloading a new (never purchased app) and it does the same thing.  Waiting...


              Will try with that tomorrow.

              • 4. Re: Sync FM Go and FMP 12
                harringg

                I deleted FM Go, (had to re-install from iTunes, download wouldn't work via wifi from iTunes store).  Opened bSource.fmp12 (from email) and nothing happned, it didn't show in FM Go.  Opened bTarget.fmp12 just fine.  Re-opened (Open in...) bSource.fmp12 and it shows up as bSource-1.

                 

                FM Go seems buggy, which may be leading to my issues.

                 

                When I try to run the Import to Remote script from bTarget on iPad, it says: The file "bSource.fmp12" could not be opened (Not Found).  I'm guessing it's because it's now named bSource-1.