0 Replies Latest reply on May 13, 2012 3:53 PM by ceguncheon

    IWP locking unlocked fields?

    ceguncheon

      My first post.

       

      Had a weird experience and wonder if anyone else has ever encountered it.

       

      I have a client who is using IWP. When I originally created their layouts, several text boxes were not accessible in Browse or Find modes. Later on in the process, before the db went live, I changed those fields so they're now accessible in both Browse and Find modes. Using FM Pro Advanced 11, no problem. When I tested the db on my system (using FM Server Advanced and the developer's method for using IWP) everything worked fine. When I moved it out to my client's, at first I thought there was an unacceptable time lag in accessing the data through IWP ... and then I discovered they couldn't access it at all. That's when I finally noticed that some of the text boxes (the ones that had never been locked and the ones that use drop-down and pop-up lists) worked just fine. Also, if there was data in one of the "inaccessible" fields (previously entered when the db was on my system), that data could be edited ... but not entered in the first place.

       

      I have replaced all the inaccessible text boxes with new never-been-locked text boxes. I'll know tomorrow after I visit my client whether this system works. In the meantime, does this situation sound familiar to anyone?

       

      TIA

       

      -ceguncheon