5 Replies Latest reply on May 31, 2012 7:46 AM by nella

    Merge Field

    nella

      The thousands separator is not showing up in the merge field. Is there a fix for this?

       

      Thanks

        • 1. Re: Merge Field
          brsamuel

          Select the item on the layout.

          At the bottom of the Data tab of the inspector change the Format to Decimal.

          Check the box for "Use thousands indicator"

           

          optional - Set the number of decimal places to an appropriate value.

          • 2. Re: Merge Field
            comment

            Note that:

             

            1. The "item" you need to select is the text object containing the merge field;

             

            2. The formatting will be applied to ALL number fields contained by the text object.

            1 of 1 people found this helpful
            • 3. Re: Merge Field
              nella

              That's been done. It shows in the original field just fine, it is the merge field that's not showing the thousands separator.

              • 4. Re: Merge Field
                erolst

                Formatting is an attribute of the layout object, not part of the field definition. On a layout, there are no “original fields”,

                only objects which you can format. This also means that you can use the same field several times on the same layout,

                with different formatting options.

                 

                Therefore, if you have a “normal” instance of the field formatted with a Thousands separator, and use that same field in a Merge Field object,

                you need to format the Merge Field, too (though of course there's no need to use the same formatting for both).

                1 of 1 people found this helpful
                • 5. Re: Merge Field
                  nella

                  I changed the General to Decimal in the inspector, checked the thousands separator and it works.

                   

                  Thank you Michael and Erolst.