AnsweredAssumed Answered

Finds on one field failing

Question asked by RossHurley on Jun 6, 2012
Latest reply on Jun 17, 2012 by RossHurley

Hi all,

 

I've run out of options in trying to fix a field in a client's system where Finds are failing. I've done everything I can think of without success, and hope the wider commuity can point me in other directions or, even better, tell me exactly what's going on.

 

It's an all Windows FM8 setup (a client I haven't heard from in a long while) running their system on FMS8 on a virtual server set up on their Windows box by their IT support company. The server crashed last weekend and their IT company restored it and replaced the files with the latest backup. The client then found that certain scripts weren't working properly. IT support restored files from 2 days before the crash but that didn't work either. As a FileMaker issue they called me in to help.

 

On investigation I concluded that it was caused by one field where Finds were not working. It's a calculated text field, unstored because it references related fields. All Finds return all records regardless of the criteria entered.

 

Steps I've done to find and fix the problem:

1. Looked at field type and indexing of the problem field. All OK - field type was text and, because of the related references, couldn't have the index rebuilt.

2. Tested the oldest backup I could get on my local Mac and found that it worked. Thought I'd gone back far enough to get past the corruption. Imported their data into a clone and replaced the file on Server. Still failed.

3. Copied the file I uploaded to the Server back to my Mac in case Server had corrupted it - worked fine.

4. Put the file onto a fresh install of FMS8 on my XP machine and tested it - worked.

5. Put the file onto a fresh install of FMS8 on a client's XP machine and tested it - failed.

Current status - it's failed on two FMS8 setups and worked on one, and it's worked when run locally on one machine. So the problem is not when running on the client's virtual server.

6. Rebuilt the indexes to all fields that were referenced in the field's calculation. Still failed.

7. Rebuilt the field from afresh, hand building the whole calculation. Interestingly, when viewed in Browse mode no data showed in the field. Commented out my calculation and pasted in the calculation from the original field. Data showed but Finds still failed. Does the fact that no data showed from my original calculation offer a clue?

8. Ran a test Recover - reported no problems and was safe to use going forward. Tested with FMDiff and this also reported no problems.

 

That's it. I'm out of ideas. Can anyone offer any help?

 

Ross Hurley

Adelaide, Australia

Outcomes