1 Reply Latest reply on Jun 12, 2012 8:36 PM by timcimbura

    Conversion to v12 - Problem with Scripts

    RecPro

      Hi,

       

      I have been converting a moderately complex three file solution. The conversion appears successful except for the fact that 8 of the script folders in the v11 file are not converted to v12. The scripts or sub folders in the v11 folders are converted, but not the folders themselves. Then when attempting to edit the script display in v12, any changes, such as re-odering folders or scripts, are lost when re-logging into Manage Scripts.

       

      The Conversion log shows "Rebuilding script catalog order list: quick reference, name, custom" and what looks like a step for "Recovering: script ... " for each script in the solution. There are no errors that show in the Conversion log except near the end with error "8496 Balanced out begin and end folder markers".

       

      I have tried Save As Copy to the v11 file and also tried coverting a Clone copy of the v11 file, but the results are the same.

       

      Any ideas what is happening and/or how to resolve the problem? It is very difficult to navigate through the script libary without the organizing folders. Plus it appears that any new script or folder will have to go at the end of the script library.

       

      Thanks in advance for any help,

      Paul

        • 1. Re: Conversion to v12 - Problem with Scripts
          timcimbura

          This seems like it could be a corruption in your original file. Could you try doing a FileMaker 11 recover of the file? Does it do the same thing?...that is mess up the script folders?

           

          If so, I would try moving all the folders out of the scripts or doing a mass copy/paste of some of the affected scripts to see if they get cleaned up in the delete/and recreation. Just some ideas...

           

          Tim Cimbura

           

          Helping businesses become more effective, productive, and profitable through custom iPad/iPhone applications, FileMaker app solutions, and web site design.

          tim@cimbura.comhttp://www.cimbura.com