1 2 3 Previous Next 43 Replies Latest reply on Jan 27, 2013 3:10 PM by acohensitt

    Bug in New Window

    keysolutions

      Recently I migrated a FileMaker 11 database to 12.

      Unfortunatly I’m not all to happy with it.

       

      What’s the problem? I’m using a number of popups (which is nice to use on Mac!) for choosing contents.

      With FM11 this was absolutly no problem.

       

      Since I migrated the database to FM12 I stumble onto a very big problem. Opening the new window causes a number of times a freeze of the database.

      If I have a look into the debugger about 90% of the times it happens the cause is opening up a new window. The other 10% is caused by a pause in the new window.

       

      To get rid of this I have to stop the script (sometimes the script has already finished, so there is nothing to stop), save a copy of the file (which fortunatly is possible) and kill the FM process.

       

      I have tried to play with the new options in the ‘new window’ script step, but nothing seems to help.

       

      Since a number of my solutions use this technique I not all to eager to switch to FM12.

      This database is my own so if anything happens, bad luck, I always have my backup. But I don’t want to take risks with customer databases.

       

      Anyone else having this problem?

      Anyone with some bright ideas about solving this problem?

       

      I’m using an iMac with Mac OS X 10.7.4 and FM Advanced 12.

        • 1. Re: Bug in New Window
          taylorsharpe

          That is not a normal window behavior in FM 12.  I recommend you reinstall FM 12.  Opening windows or pausing script steps all work just fine in FM 12 and I've done it on my different machines, Windows, Macs, and various OSs.  So rest assured, there is some problem.  Have you  tried recovering it?  Or how about opening it from a different machine?  Or a different volume (e.g., external hard drive)?  Have you tried it on FM Server?  I would first start with the reinstall, but would then try this other things.  I've had people tell me their FM was doing weird things like this only to find out after a few days that their hard drive was dying or their memory is bad.  I've run into the hard drive problem a number of times myself. 

          • 2. Re: Bug in New Window
            TimAnderson

            Confirm I do not get this beaviour with same OS as you.

             

            DO you have the script doing anything else apart from creating the new window, such as pausing script?

            • 3. Re: Bug in New Window
              Stephen Huston

              I encountered and reported similar issues with new windows during the pre-release version of FMA12. By then FMInc didn't want to hear about "bug reports" as the software was scheduled for release.

               

              • First, one must be very careful not to lock yourself into a modal window without a button to allow you to close it. If you do, then FMP12 is stuck. I had to force-quit a couple of times from this situation before I learned to avoid it.
              • Second, and more worrisome, has to do with the New Window script step itself. I found that attempting to modify a New Window script step converted from 11 to 12 would, often but not always, crash FM12. The worst offender was when trying to change window settings such as position or size of the window -- options in that script step which were often not specified in 11, but worked OK. This one worries me most because it is something I've often needed to do when updating a script on live served files in 11 and older versions.

               

              I did not have this problem with the dialog if the script I was editing had been built from the ground up in 12, only with converted scripts. I suspect there is enough difference in the New Window script step options between 11 and 12 that the missing info which was optional in 11 or is new to 12 is not letting the old and new settings play nicely when the window options set in 11 are touched in 12.

              • 4. Re: Bug in New Window
                keysolutions

                The most troublesome part of this problem is that it occurs on different scripts.

                I have scripts that just open a new window (some in which I need to go to related records), but there are also scripts that indeed pause to wait for an action.

                In both cases this problem occurs.

                • 5. Re: Bug in New Window
                  keysolutions

                  It”s brand new Mac, and FileMaker is the only application which gives me trouble. So it’s not quite obvious to look for a hardware related problem (besides the fact I only have one computer which FM12 runs on).

                  I did migrate from an older Mac. And although the installation of FM12 was fresh (not even the pre-release has been installed) I removed everything and reinstalled.

                  Now I just have to play on and see if it keeps stable.

                  • 6. Re: Bug in New Window
                    keysolutions

                    The only ways out in this is doing it through the debugger. Even the close window script doesn’t do the job.

                    What I haven’t tested yet is building the script from scratch. I do modify the position/size of the new window to get it on the correct position and size.

                     

                    You all have given me some new inspiration to look into. I’ll report back soon.

                    Thanks.

                    • 7. Re: Bug in New Window
                      maximums

                      I too have been experiencing this behaviour. Interestingly, I can close non-file windows, ie. Manage Layouts and Manage Scripts windows as well as scripts. I can also bring other open file windows to the front, but I can't close any of them.

                       

                      The files I am working with are converted files from v11. I have recovered the files without errors. I have saved clones, exported the data from the original files, then imported the data back into the cloned copies. Some of the windows that lock up are displaying layouts created in v11, others created in v12.

                       

                      cheers

                      Linda

                       

                      Message was edited by: maximums—typo

                      • 8. Re: Bug in New Window
                        taylorsharpe

                        I guess you have tried the obvious things I would try.  I might try changing themes to get it away from the classic theme and into one of the new CSS styled themes and see if that works.  If it doesn't, then I would recreate the whole layout (what a pain) and see if it works. 

                         

                        Someone more in the know than me commented that converted layouts from 11 are much larger in size than new clean ones using the 12 themes.  You might want to try to recreate your layout using a 12 theme and see if it all works then.  Yes, it is a pain recreating layouts and most of mine I have not recreated either.  But I would try that next. 

                        • 9. Re: Bug in New Window
                          keysolutions

                          Last week I have tried serveral option given in the replies, but unfortunatly none of the suggestions that are reasonably doable have helped.

                          The problem still occures.

                           

                          One thing I have seen is a loggin in the System Log, of which I cannot make any chocolate... but perhaps someone can see from there where to look to get rid of this very nasty bug (at least from this point of view I still consider it a bug since this behavior was not present in FM11!).

                           

                          Below s the latest logging. I’m not sure the last line also belongs to this error. The error I got in the debugger is 112. The new window didn’t popup, but mostly it does, and behavior is the same. Lock up of the file, only solutions is to kill the FileMaker process.

                           

                          -------

                           

                          23-06-12 12:18:24,540 FileMaker Pro: *** Assertion failure in -[FMXApplicationMenu itemAtIndex:], /SourceCache/AppKit/AppKit-1138.47/Menus.subproj/NSMenu.m:850

                          23-06-12 12:18:24,541 FileMaker Pro: Invalid parameter not satisfying: (index >= 0) && (index < [_itemArray count])

                          23-06-12 12:18:24,571 FileMaker Pro: (

                                    0   CoreFoundation                      0x9c546a67 __raiseError + 231

                                    1   libobjc.A.dylib                     0x95331149 objc_exception_throw + 155

                                    2   CoreFoundation                      0x9c4ae289 +[NSException raise:format:arguments:] + 137

                                    3   Foundation                          0x93cae233 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 116

                                    4   AppKit                              0x99ecb972 -[NSMenu itemAtIndex:] + 175

                                    5   FileMaker Pro                       0x0061c3b9 -[FMXApplicationMenu ChangeNotification:] + 169

                                    6   Foundation                          0x93beadf1 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 49

                                    7   CoreFoundation                      0x9c486903 ___CFXNotificationPost_block_invoke_1 + 275

                                    8   CoreFoundation                      0x9c451688 _CFXNotificationPost + 2776

                                    9   Foundation                          0x93bd5fde -[NSNotificationCenter postNotificationName:object:userInfo:] + 92

                                    10  AppKit                              0x99eb0894 -[NSMenu itemChanged:] + 253

                                    11  AppKit                              0x99eb0792 -[NSMenu _postItemChangedNotificationButIgnoringItOurselves:] + 40

                                    12  AppKit                              0x9a376c7e -[NSMenu _menuItem:didChangeEnabledStateFrom:to:] + 43

                                    13  AppKit                              0x99eada0f -[NSMenuItem setEnabled:] + 105

                                    14  AppKit                              0x9a0aca90 -[NSEditableBinder _setStatesImmediatelyInObject:mode:triggerRedisplay:] + 1054

                                    15  AppKit                              0x9a0ac66b -[NSEditableBinder _observeValueForKeyPath:ofObject:context:] + 123

                                    16  AppKit                              0x99ec7176 -[NSBinder observeValueForKeyPath:ofObject:change:context:] + 420

                                    17  AppKit                              0x99ec6fcd -[NSBinder _performConnectionEstablishedRefresh] + 82

                                    18  AppKit                              0x99ec54ca -[NSBinder establishConnection] + 367

                                    19  AppKit                              0x99eb84f3 -[NSObject(NSKeyValueBindingCreation) bind:toObject:withKeyPath:options:] + 775

                                    20  AppKit                              0x9a0d399b -[NSNibBindingConnector establishConnection] + 147

                                    21  AppKit                              0x99eb1195 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1129

                                    22  AppKit                              0x99fd62f1 -[NSNib instantiateNibWithExternalNameTable:] + 652

                                    23  AppKit                              0x99fd6030 -[NSNib instantiateNibWithOwner:topLevelObjects:] + 304

                                    24  AppKit                              0x99fd54a6 -[NSViewController loadView] + 212

                                    25  FileMaker Pro                       0x00459ca0 -[FMFormattingViewControllerCocoa initWithPropertyModel:docWindow:] + 128

                                    26  FileMaker Pro                       0x00424f16 -[FMDocWindowControllerCocoa ConnectToDocWinControllerMac:] + 134

                                    27  FileMaker Pro                       0x0041effd _ZN19DocWinControllerMacC2ER11FMDocWindowRKN5Draco9unistringERKNS2_5XRectEP15CocoaWindowTypebb + 269

                                    28  FileMaker Pro                       0x002233e1 _ZN11FMDocWindow17CreateOwnerWindowERKN5Draco5XRectES3_bb + 449

                                    29  FileMaker Pro                       0x00223c1e _ZN11FMDocWindowC2ERKS_RKN5Draco13HBAbstractKeyEPKNS2_9unistringEPKNS2_5XRectEl + 1326

                                    30  FileMaker Pro                       0x0017b06e _ZNK12FMAppSession18CreateWindowObjectERKN5Draco13FMWindowModelERKNS0_13HBAbstractKeyEPKNS0_9unistringEPKNS0_5XRectEl + 126

                                    31  FMEngine                            0x0414b07d _ZN5Draco9FMSession10OpenWindowERKNS_10FMFileUserEPKNS_13FMWindowModelEPKNS_9unistringEPKNS_5XRectEbbPKNS_13HBAbstractKeyEl + 205

                                    32  FMEngine                            0x0416707d _ZN5Draco17ScriptRuntimeBase14DoCreateWindowEPKNS_10FMFileUserEb + 573

                                    33  FMEngine                            0x041704d9 _ZN5Draco17ScriptRuntimeBase12DispatchStepEv + 4249

                                    34  FMEngine                            0x04171295 _ZN5Draco17ScriptRuntimeBase7ExecuteEv + 597

                                    35  FMEngine                            0x04171d03 _ZN5Draco17ScriptRuntimeBase10DoNextStepEv + 371

                                    36  FMEngine                            0x04171e2d _ZN5Draco17ScriptRuntimeBase9DoRunLoopEv + 109

                                    37  FileMaker Pro                       0x0032152f _ZN13ScriptRuntime6OnIdleEv + 127

                                    38  FMEngine                            0x0414be70 _ZN5Draco9FMSession6OnIdleEb + 272

                                    39  FileMaker Pro                       0x0017b2a2 _ZN12FMAppSession6OnIdleEb + 66

                                    40  FileMaker Pro                       0x0016ae65 _ZN9CFMProApp4IdleEb + 69

                                    41  FileMaker Pro                       0x0016af8d _ZN9CFMProApp17DispatchNullEventEv + 109

                                    42  FileMaker Pro                       0x004b29d9 -[MFAppDelegate HandleIdleNotification] + 25

                                    43  Foundation                          0x93beadf1 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 49

                                    44  CoreFoundation                      0x9c486903 ___CFXNotificationPost_block_invoke_1 + 275

                                    45  CoreFoundation                      0x9c451688 _CFXNotificationPost + 2776

                                    46  Foundation                          0x93beadb7 -[NSNotificationCenter postNotification:] + 115

                                    47  Foundation                          0x93c52803 postQueueNotifications + 948

                                    48  CoreFoundation                      0x9c46a0ce __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ + 30

                                    49  CoreFoundation                      0x9c46a00d __CFRunLoopDoObservers + 413

                                    50  CoreFoundation                      0x9c43ca5d __CFRunLoopRun + 1261

                                    51  CoreFoundation                      0x9c43c1dc CFRunLoopRunSpecific + 332

                                    52  CoreFoundation                      0x9c43c088 CFRunLoopRunInMode + 120

                                    53  HIToolbox                           0x9bf62723 RunCurrentEventLoopInMode + 318

                                    54  HIToolbox                           0x9bf69a8b ReceiveNextEventCommon + 381

                                    55  HIToolbox                           0x9bf698fa BlockUntilNextEventMatchingListInMode + 88

                                    56  AppKit                              0x99e9e0d8 _DPSNextEvent + 678

                                    57  AppKit                              0x99e9d942 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 113

                                    58  AppKit                              0x99e99cb1 -[NSApplication run] + 911

                                    59  FileMaker Pro                       0x0006ef20 CMacApp_Main + 576

                                    60  FileMaker Pro                       0x001704d3 main + 67

                                    61  FileMaker Pro                       0x00050fd5 start + 53

                          )

                          23-06-12 12:18:54,600 xpchelper: Invalid file permissions (0100666) for cache archive : /var/folders/zz/zyxvpxvq6csfxvn_n00000b400002s/C/com.apple.xpchelper.cache

                          • 10. Re: Bug in New Window
                            tweller860

                            We have also experienced this issue when migrating from FM11 to FM12.  Most of our office users are using iMacs with networked home directories.  Due to issues following our FM10 to FM11 conversion, I had blamed a file system permission issue as the source of the problem. 

                             

                            Finally, I saw the problem happen and was able to open the debugger to see what was happening in the background.  In that instance and every time since then when I've been asked to look at a system that was frozen, a script was running that was either trying to use the "New Window" script step or the "Go To Related Record" script step with the "Open in new window" option checked.  I was able to exit the script but things still weren't "right", usually requiring a Force Quit of FMPA.

                             

                            You noted that you had tried several of the suggestions listed above  in the replies.  I've tried setting some the new window options in the script steps, but I have not tried building the affected scripts from scratch in FM12.  Before I go this route, have you attempted building new scripts from the ground up?


                            TW

                            • 11. Re: Bug in New Window
                              keysolutions

                              I’m not sure if it isn’t a permission error, but hope some from FM can have a look at the loggingI posted.

                               

                              I don’t think rebuilding the script(s) will help you much. I tried it it with one of the scripts, but it didn’t result in getting rid of the error. Also I have tried to modify the behavior of the script in using smaller steps, but also without the desired result.

                               

                              The most anoying part of this error is I cannot reproduce it if wanted. It just happens. Sometimes after opening up a few new window, but it may also keep away until a couple of dozen windows have been opened.

                               

                              You don’t want to use just a client when having these kinds of trouble since it most likely will destroy the database.

                              Rebuilding the database can hardly be an option. It has about 40 tables, some 100 layouts and dozens of scripts/buttons/relations.

                              The base table has some 65.000 records and the size is 2.5 GB.

                              • 12. Re: Bug in New Window
                                Stephen Huston

                                I assume this is happening with scripts which contain the New Window script step which were written and converted pre-12. As I mentioned a week or so ago:

                                Second, and more worrisome, has to do with the New Window script step itself. I found that attempting to modify a New Window script step converted from 11 to 12 would, often but not always, crash FM12. The worst offender was when trying to change window settings such as position or size of the window -- options in that script step which were often not specified in 11, but worked OK. This one worries me most because it is something I've often needed to do when updating a script on live served files in 11 and older versions.

                                I recommend that you set all New window script steps to have ALL options filled in even though these worked with blanks in FP7 files. You will probably encounter some freezes when making modifications (via server for safety), but eventually, as they "take" there should be fewer things that cause errors in 12. The options in FMP12 include things which didn't exist in FP7, and the conversion of this script step seems to problematic for many users.

                                 

                                There has still been no word from FMInc about this known pre-release bug.

                                • 13. Re: Bug in New Window
                                  timcimbura

                                  Just wondering if this issue can be fixed by deleting the offending New Window or Go To Related Record script step...and then recreating it natively in FileMaker 12. This could be a lot of work but potentially fix the issue without waiting for a bug fix from FileMaker.

                                  This would be consistent with the idea that the script step somehow is messed up in the conversion from 11-12 but creating scripts natively in 12 doesn't exhibit the issue.

                                  • 14. Re: Bug in New Window
                                    keysolutions

                                    One of the steps I have taken in an attempt to get rid of this problem was rebuilding the complete script in FM12 from scratch.

                                    Unfortunatly it didn’t help. The problem still exists.

                                     

                                    It is not a problem in one particular script, there are a number of scripts (within the same database) that have this behavior.

                                    Some open a new window directly, others use the related record stcript step.

                                    Also the direction they go is different layouts.

                                     

                                    In short: different scripts, different layouts, different tables > same problem.

                                    And a not so happy developer.

                                    1 2 3 Previous Next