jcooper

Vanishing Objects on Layout FMP12

Discussion created by jcooper on Jun 18, 2012
Latest reply on Aug 2, 2012 by Stephen Huston

I tried submitting this as a bug but amd having some screwy account trouble so while I wait for the west coast to get to work...

 

Has anyone else had a problem with objects vanishing from a layout? Here's what happens:

 

I have a Listview layout. The header and footer each have a couple global fields and some buttons. While in browse mode, from that layout, I navigate to another Form view layout. When I go back to the original listview layout, three of my footer buttons are gone. If I enter Find or Preview mode, they return.

 

The file is converted from .fp7 but I removed/remade all styles using the new layout tools.

 

  • The offending objects are not hidden behind something.
  • No custom formatting on them.
  • I do have a couple script triggers on the layout (onLayoutEnter and onRecordLoad) but disabling them had no affect on this.
  • If I move them to the body or the header, they do not vanish.
  • If I move them to a different part of the footer, they vanish.
  • If I duplicate the layout, it has the same effect (they vanish).
  • If I make a new layout from scatch and copy all items to it, they vanish.
  • If I create a new button from scratch and copy the style from an old one that vanished, it vanishes.
  • The only thing that makes it not vanish in this case, is anchoring it to the right of the layout.

 

Once I change modes, or go to and return from different listview layout, they reappear.

 

I'm a bit perplexed. Anyone else see this?

 

Thanks,

 

Jeff

 

 

Here are before and after screenshots to be sure I'm not just going bonkers.

 

Screen shot 2012-06-18 at 8.26.38 AM.png

 

Screen shot 2012-06-18 at 8.25.39 AM.png

Outcomes