0 Replies Latest reply on Jul 24, 2012 1:10 PM by phoward8020

    "Save as PDF" - Works on 1st gen. iPad but not 3rd?

    phoward8020

      UDPDATE:

       

      For the sake of any future developers who run into the same issue: this appears to have been caused by a glitch in the installation process of FileMaker Go. Simply deleting, then reinstalling the app restored the ability to write PDFs to the app's sandboxed Documents directory.

       

      I'd love to know if this was a one-in-a-million bug or if anyone else has experienced it, so please let me know by replying to this thread if you've also had a problem saving PDFs in FileMaker Go, and let me know if deleting/reinstalling fixed it for you, too.

       

      -- Paul --

       

      ----------------------

       

      ORIGINAL POST:

       

       

      Is this a known bug? Am I missing a local setting on the iPad 3? I'm tearing my hair out here.

       

      Steps to Reproduce:

       

      1) Create script with the following steps:

       

      • Set Variable [ $fileName; Value:"Test File" & Get ( CurrentTime ) & ".pdf" ]
      • Set Variable [ $docPath; Value:Get ( DocumentsPath ) & $fileName ]
      • Save Records as PDF [ File Name: “$docPath”; Current record ] [ Document - Compatibility: Acrobat 7 and later ] [ Pages - Number Pages From: 1; Include: All pages ] [ Security - Printing: High Resolution; Editing: Any except extracting pages; Enable copying; Enable Screen Reader ] [ Initial View - Show: Pages Panel and Page; Page Layout: Single Page; Magnification: 100% ] [ Restore; No dialog ]
      • Show Custom Dialog [ Title: "FM GO Doc Directory Listing"; Message: Get ( DocumentsPathListing ); Default Button: “OK”, Commit: “No” ]

       

      2) Connect to database file on remote host using an iPad 1G and an iPad 3G (both running iOS 5.1.1 and FM Go 12.0.4) and run script.

       

       

      Actual Results:

       

      On 1st gen. iPad, final step shows Dialog that looks like this (assuming previously empty Documents directory):

       

      success.jpg

       

      On 3rd gen. iPad, Dialog looks like this:

       

      fail.jpg

       

      Further inspection shows that file was indeed saved as expected on iPad 1G, and that no file was saved on iPad 3G.

       

       

      Expected Results:

       

      Expected same result from both iPads.

       

      So...anyone?