5 Replies Latest reply on Aug 30, 2012 10:18 AM by cooldan

    Printer script step won't save settings.

    cooldan

      I can't get FMP 12 to remember printer setting "reverse page orientation" in print script step. Envelopes print wrong side first. Mac Lion.

      I use Print Setup & then Print script steps.

      I set the Printer settings I want, but they won't print that way, & they won't save in the Print script step.

       

      This is a database I have used for many years, starting with FMP 5.5.

      Envelopes have always printed OK until I ungraded to FMP 12 from FMP 11.

      Envelopes no longer printed left side first & when I finally came upon "Reverse Page Orientation" in Layout, I thought I had solved the problem, BUT the settings won't save & envelopes still print incorrectly.

      Printers are all HP & envelopes center feed, left side first.

       

      I print several differant page & envelope layouts from this file, so a default setting is not usable.

       

      Any suggestions would be very appreciated.

       

      Dan

        • 1. Re: Printer script step won't save settings.
          AlanStirling

          Hi Dan

           

          Just go with the flow ...

           

          Why not rotate the address by 180° on the layout and forget about trying to get the printer to remember the tray settings?

           

          Best wishes - Alan Stirling, London UK.

          • 2. Re: Printer script step won't save settings.
            cooldan

            I don't think that would work due to the large number of layouts, but the problem doesn't exist on my other MAC's using same OS & FMP versions.

            I also am of the old school that likes to know why.

            I am fairly certain that it must have something to do with some kind of saved preferences in the layout scripts, but I can't find a way to change them.

            Thanks for the suggestion.

             

            Dan

            • 3. Re: Printer script step won't save settings.
              cooldan

              I have solved the problem, but I don't know if it will work with everyone. The problem occurs when you have  Adobe Acrobat 7.0 on your MAC prior to Mac Lion. An extension/plugin from Adobe "Adobe PDFPDE700". It is listed in Print selections as "Unsupported PDFPDE700".

               

              To cure the problem, open you filemake database that you print any "reverse page orientations" from, select all files, export all files to an text file or FMP file. This is to preserve your data.

               

              Then remove Adobe 7 & all related files from your computer "BEFORE DOING THE FOLLOWING." You can get the instructions & file list from Adobe.com. This step is mandatory, as far as I can tell.

               

              You now need a copy of you database prior to FMP 12. I got mine from Time Machine by looking at my application folders until I found a backup without FMP 12. I then restored the database to my current desktop. Converted it to FMP 12, deleted all records, then imported from the previously saved exported file.

               

              I then verified the total records & tested a few for correctnesss.

               

              Prints now accept "reverse page orientation" & print correctly.

               

              This was an Adobe mixup when they quit supporting the Apple printing system. A Heads up would have saved me many days of hassle.

               

              There may be another way to achieve this, but I haven't found it & no one else has come up with a cure.

              • 4. Re: Printer script step won't save settings.
                cooldan

                Turns out that this can't be a full solution.

                 

                I have encountered the same problem with the "Print" sciprt step not remembering the "reverse page orientation" setting in FMP 12 on MAC OS Lion. Different computer where one file does remember & another file does not. the file the remembers was converted from FMP 11. The new file was designed in FMP 12 fully. Can't print envelopes correctly. BIG PAIN IN THE BEHIND.

                • 5. Re: Printer script step won't save settings.
                  cooldan

                  This fix seems to be a random one. I am now getting the same  "Print" sciprt step not remembering the "reverse page orientation" setting in FMP 12 on MAC OS Lion In a new data base without Adobe 7 instatlled. I am getting extremely frustrated. I never had this kind of problems in FMP 5.5.