1 Reply Latest reply on Sep 8, 2012 3:11 PM by wsvp

    Issue with Perform Find in Filemaker 12 Server script

    sysjm

      Hi - I have been using filemaker for years and one of my solutions has a nightly "Batch Script" scheudled to run at 1am via the server every night - One of the rotuines in this script is to find some accounts that are past due and write them to specific queue/table to be worked by staff in the morning. The script is pretty basic it just does a find on some criteria and then I write it to a table each account that was found. This has been running every night in filemaker 11 for years now that I have moved to Filemaker 12 for some reason I'm getting a script error that "no records are found" - If I ran the same script live it works just fine - It only happens when the script is executed by the server. Has anyone else encounted this issue? - I put a quick and dirty work around in (which is better anyway) where I find the records via an SQL statement then go to a related table (self-join) and run through each record to process - This is just bothering me that I can't fiqure out why this "Perform Find" is not working. (I did build a debug table to write all the criteria so I can see if something is missing - All data is present, just for some reason the find is not working) I would love to hear feedback.

       

       

      Thanks!

        • 1. Re: Issue with Perform Find in Filemaker 12 Server script
          wsvp

          Not sure this is the issue, but it may have to due with the "≠" or "<>" being in one of the search parameters.  There is a bug with FM12 related to these expressions.  From what I remember it only appeared when using FM12 remotely.  I don't remember all the specifics.  But I remember seeing some posts related to this, as well as FileMaker update info on this.