8 Replies Latest reply on Sep 12, 2012 11:36 AM by MEC

    Problem with global date field, possible corruption---SOLVED

    MEC

      This is FileMaker 11 advanced on Mac Snow Leopard, the server is FMS 11 on another Mac running the same OS.

       

      One of my clients db''s is showing weird behavior. This is on a report screen in list view. There is a global Beggining Date field and a global Ending Date field. The user is prompted to enter the dates for the date range of the report, then the script runs and all is wonderful in the world of FM!

       

      I've used this scenario a lot and never had an issue. The problem I'm seeing now: I can enter a new date once or twice in either of the fields, and then I can't enter a date until I leave the layout and use a script to come back in (this script sets the ending date to today, and the beginning date to 7 days earlier (as a default when hitting the layout). This scripted entry works everytime. The other odd behavior is when using the drop down calendar or just tabbing or clicking into the field without the drop down will some times act as though it's clearing the field. I can refresh or commit and it's still the same, BUT if I start clicking away in the field, I'll eventually see a date, and it's the date entered by the script.

       

      I opened a copy of this file, without the latest changes (I built the file, and I made the changes) from 8 months ago, and this issue is not there. I've restarted my development box, I've restarted my fm server box, and made a compacted copy and nothing fixes the problem. I've also hit the served file from another box with the same results.

       

      In the past, whenever I've seen off the wall strange behavior in FM, it's been a corrupt file.

       

       

      Any thoughts?