4 Replies Latest reply on Sep 27, 2012 1:50 PM by jamesg

    IWP showing only two out of three databases

    jamesg

      Hi All

       

      I have limited experience using FMSA 12. In the past I have had a full time developer guide me through setting up our system however now I'm on my own and wanted to make one of our databases accessible via IWP.

       

      The server is an iMac running OS10.6.8, the FMSA is version 12.0.1.178.

       

      I have a company project management database linked to a second database or historic records, and then I host a database for a client.

       

      Until last week we only wanted to have the hosted database for the client accessible via IWP. I have just finished developing some functionality in the company project management database that would benefit us to be available on IWP.

       

      The historic records database has published correctly, however the company project management database isn't visible, and in the admin console under IWP column heading the icon is a half circle.

       

      I have compared the privilege sets between the databases and they all match.

       

      I have checked that the layouts that I are all classic theme.

       

      I have a firewall on the network and we have a static IP, the homepage is accessed via http://domainname/fmi/iwp/res/iwp_home.html

       

      Would anyone be able to suggest what to check/change in order to make the project management database accessible by IWP?

       

      Many thanks in advance.

       

      James

        • 1. Re: IWP showing only two out of three databases
          BowdenData

          James,

           

          I don't have a specific answer, but you should be able to sort this out by looking in the documentation. Two places to look in.

           

          A pdf file called "fm12_instant_web_publish_en.pdf". This would have been included with your copy of FileMaker 12 client (and I think server). One about page 3-4, they talk about hosting for IWP and more relevant, starting on about page 33, several pages about working with FM Server Advanced and IWP. Guessing a bit, check the setting that says "Don't show this dB on IWP home page" that is referred to near the beginning of this document.

           

          The other place is in the on-line help in FM server itself. There are several areas where IWP is discussed. Bring up the Help and search for "IWP".

           

          Sorry I couldn't be more specific...but confident that you can find the answer.

           

          Doug

          • 2. Re: IWP showing only two out of three databases
            jamesg

            Thanks Doug for the fast reply.

             

            On all three databases IWP is managed by FMSA.  I've read that the databases should be 'shared' either via FM Pro or the FMSA not both, and therefore the setting 'do not show on homepage' is off in the FM Pro Sharing menu item.

             

            I'll read through the sections you mentioned, thank you.

             

            James

            • 3. Re: IWP showing only two out of three databases
              BowdenData

              James,

               

              Agree that when on the FM server, all you need is to have the FMIWP extended privilege enabled in each file. There isn't an equivilent "Don't show" setting from the server perspective though. I am not able to test this currently, but something in the back of my mind says that this local FM client setting carries over with the file when it is hosted on a FM server.

               

              HTH.

               

              Doug

              1 of 1 people found this helpful
              • 4. Re: IWP showing only two out of three databases
                jamesg

                Hi Doug

                 

                Although I haven't tested this on my project management database I tested on a test db and you're absolutely right, somehow that setting is carried over to the uploaded server hosted file but you can't tell that that's the case by simply checking sharing, it appears not to be set.

                 

                When it's a little quieter I will remove the hosted file, change the setting and upload back to the server, reckon it'll work - will let you know.

                 

                Thanks again!

                 

                James