MarkB

Scriptmaster RegisterGroovy Error

Discussion created by MarkB on Oct 1, 2012
Latest reply on Oct 1, 2012 by MarkB

Hey all,

 

We recently did a full upgrade of our office from FMP11 to FMP12, and we are noticing little quirks. The major one that we are experiencing has to do with 360 Works Scriptmaster. We have a custom function that is run on entering a layout that registered a function called "CatPDF" which when run would take one pdf and place it at the tail end of the target pdf. While in FMP11 the script worked fine and the function was registered with the RegisterGroovy function, however we are finding out that in FMP12, the function doesn't get registered. When checking in the debugger with a data viewer on, I can see that the RegisterGroovy function returns an error. Tried recreating the custom function to no avail. Below is a screenshot of the function. I would be grateful for any help in this:

 

CatPDF code.jpg

 

That is from the custom function we call "sm.register.catpdf". When we call it in a script we call it to a variable like so:

 

Set Variable [$$registerCatPDF; Value:sm.register.catpdf]

 

The above returns an error in FMP12, when it worked like a charm in FMP11. Any ideas?

Outcomes